Using
ADOBE® FLASH® CATALYST™ CS5
This user guide is protected under copyright law, furnished for informational use only, is subject to change without notice, and should not be construed as a commitment by Adobe Systems Incorporated. Adobe Systems Incorporated assumes no responsibility or liability for any errors or inaccuracies that may appear in the informational content contained in this guide.

This user guide is licensed for use under the terms of the Creative Commons Attribution Non-Commercial 3.0 License. This License allows users to copy, distribute, and transmit the user guide for noncommercial purposes only so long as (1) proper attribution to Adobe is given as the owner of the user guide; and (2) any reuse or distribution of the user guide contains a notice that use of the user guide is governed by these terms. The best way to provide notice is to include the following link: To view a copy of this license, visit http://creativecommons.org/licenses/by-nc-nd/3.0/

Adobe, the Adobe logo, Acrobat, Adobe AIR, Adobe Premiere, ActionScript, After Effects, AIR, Creative Suite, Fireworks, Flash, Flash Builder, Flash Catalyst, Flex, Illustrator, and Photoshop are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States and/or other countries.

Windows is either a registered trademark or a trademark of Microsoft Corporation in the United States and/or other countries. Mac OS is a trademark of Apple Inc., registered in the U.S. and other countries. All other trademarks are the property of their respective owners.


Portions include software under the following terms:

This product includes software developed by the Apache Software Foundation (www.apache.org).

MPEG Layer-3 audio compression technology licensed by Fraunhofer IIS and Thomson Multimedia (http://www.is-fhg.de/amm/). You cannot use the mp3 compressed audio within the Software for real time or live broadcasts. If you require an mp3 decoder for real time or live broadcasts, you are responsible for obtaining this mp3 technology license.

Speech compression and decompression technology licensed from Nellymoser, Inc. (www.nellymoser.com)


This product includes software developed by the OpenSymphony Group (http://www.opensymphony.com/)

This product contains either BSAFE and/or TIPEM software by RSA Security, Inc.

THE PROXIMITY/ Merriam-Webster, Inc. Database ©Copyright 1990 Merriam-Webster, Inc. © 1990 All Rights Reserved. Proximity Technology Inc.

This work is based in part on the work of the Independent JEPG Group.

This program was written with MacApp®. ©1985-1988 Apple Computer, Inc. APPLE COMPUTER, INC. MAKES NO WARRANTIES WHATSOEVER, EITHER EXPRESS OR IMPLIED, REGARDING THIS PRODUCT, INCLUDING WARRANTIES WITH RESPECT TO ITS MERCHANTABILITY OR ITS FITNESS FOR ANY PARTICULAR PURPOSE. The MacApp software is proprietary to Apple Computer, Inc. and is licensed to Adobe for distribution only for use in combination with Adobe Flash Catalyst.

Sorenson Spark™ video compression and decompression technology licensed from Sorenson Media, Inc.

Adobe Systems Incorporated, 345 Park Avenue, San Jose, California 95110, USA.

Notice to U.S. Government End Users: The Software and Documentation are “Commercial Items,” as that term is defined at 48 C.F.R. §2.101, consisting of “Commercial Computer Software” and “Commercial Computer Software Documentation,” as such terms are used in 48 C.F.R. §2.101 or 48 C.F.R. §227.7202, as applicable. Consistent with 48 C.F.R. §227.7202-1 through 227.7202-4, as applicable, the Commercial Computer Software and Commercial Computer Software Documentation are being licensed to U.S. Government end users (a) only as Commercial Items and (b) with only those rights as are granted to all other end users pursuant to the terms and conditions herein. Unpublished rights reserved under the copyright laws of the United States. Adobe agrees to comply with all applicable equal opportunity laws including, if appropriate, the provisions of Executive Order 11246, as amended, Section 402 of the Vietnam Era Veterans Readjustment Assistance Act of 1974 (38 USC 4212), and Section 503 of the Rehabilitation Act of 1973, as amended, and the regulations at 41 CFR Parts 60-1 through 60-60, 60-250, and 60-741. The affirmative action clause and regulations contained in the preceding sentence shall be incorporated by reference.
## Contents

### Chapter 1: Resources
- Activation and registration ................................................................. 1
- Services, downloads, and extras .............................................................. 2

### Chapter 2: The Flash Catalyst workflow
- General workflows ............................................................................. 3
- Start a new Flash Catalyst project ....................................................... 5

### Chapter 3: Importing artwork
- Import Adobe Illustrator files ............................................................... 6
- Import Adobe Photoshop files ............................................................. 7
- Import FXG files .................................................................................. 8
- Import bitmap images ......................................................................... 8
- Import SWF files ............................................................................... 8
- Import a Flash Catalyst library package ........................................... 9
- Import fidelity considerations ............................................................. 9

### Chapter 4: User interface
- Design workspace ............................................................................... 10
- Code workspace ................................................................................. 12

### Chapter 5: Defining structure with pages and states
- Add, duplicate, and delete pages and states ........................................ 15
- Name pages and states ..................................................................... 16
- Navigate between pages and states ................................................... 16
- Show and Hide artwork in pages and states ..................................... 17
- Share objects between pages and states .......................................... 18

### Chapter 6: Layers
- Organize a project using layers ........................................................ 19
- Selecting objects in the Layers panel ............................................... 20
- Manage artwork using layers ............................................................. 20

### Chapter 7: Library
- Manage and place artwork from the Library panel ......................... 22
- Export and import a library package ................................................. 23

### Chapter 8: Interactive components
- Create a component from custom artwork ...................................... 25
- Set component properties ................................................................. 25
- Edit-In-Place .................................................................................... 27
- Add a wireframe component ............................................................ 28

Last updated 10/13/2010
Chapter 9: Interactions and action sequences
Add interactions ................................................................. 31
Create action sequences .................................................... 31
Edit an action sequence ..................................................... 32
On Application Start interactions ....................................... 33
Conditional interactions ..................................................... 33
Conditional list interactions ............................................... 33

Chapter 10: Transitions and the timeline
Edit transitions .................................................................. 36
Smooth transition options .................................................. 39

Chapter 11: Creating scrolling images, panels, and lists
Overview of data lists ........................................................... 41
Create a data list component ................................................. 41
Add design-time data ........................................................... 42
Overview of a scroll panel ..................................................... 43
Create a scroll panel component ............................................. 43

Chapter 12: Creating shapes, lines, and text
Draw shapes and lines ............................................................ 45
Add text ........................................................................... 45
Select and position objects .................................................... 46
Size and rotate objects ........................................................ 46
Share drawn objects to other states ...................................... 47
Modify drawing and text properties ...................................... 47
Shape and line properties ..................................................... 48
Text properties .................................................................. 50
Make objects the same in all states ........................................ 51
Filters ............................................................................. 51
Blending modes .................................................................. 52

Chapter 13: Optimizing graphics

Chapter 14: Round-trip editing
Launch and edit in Adobe Illustrator CS5 ............................... 57
Launch and edit in Adobe Photoshop CS .................................. 58
Tips for preserving fidelity during round-trip editing .................. 59

Chapter 15: Video and sound
Add video ............................................................................ 60
Set video player properties ................................................... 60
Control video playback ....................................................... 61
Add sound effects ............................................................... 62
Creating video and sound files ............................................... 62
Chapter 1: Resources

Activation and registration

Help with installation
For help with installation issues, see the Creative Suite Help and Support page at www.adobe.com/go/learn_cs_en.

License activation
During the installation process, your Adobe software contacts Adobe to complete the license activation process. No personal data is transmitted. For more information on product activation, visit the Adobe website at www.adobe.com/go/activation.

A single-user retail license activation supports two computers. For example, you can install the product on a desktop computer at work and on a laptop computer at home. If you want to install the software on a third computer, first deactivate it on one of the other two computers. Choose Help > Deactivate.

Register
Register your product to receive complimentary installation support, notifications of updates, and other services.

❖ To register, enter your Adobe ID when prompted when you install or launch the software.

❖ If you choose to skip entering your Adobe ID during installation or launch, you can register at any time by choosing Help > Product Registration.

Adobe Product Improvement Program
After you have used your Adobe software a certain number of times, a dialog box appears, asking whether you want to participate in the Adobe Product Improvement Program.

If you choose to participate, data about your use of Adobe software is sent to Adobe. No personal information is recorded or sent. The Adobe Product Improvement Program only collects information about the features and tools that you use in the software and how often you use them.

You can opt in to or opt out of the program at any time:
• To participate, choose Help > Product Improvement Program and click Yes, Participate.
• To stop participating, choose Help > Product Improvement Program and click No, Thank You.

Adobe provides more information about the Product Improvement Program in a frequently asked questions (FAQ) list on the Adobe website.
Services, downloads, and extras

Adobe Exchange
Visit the Adobe Exchange at www.adobe.com/go/exchange to download samples as well as thousands of plug-ins and extensions from Adobe and third-party developers. The plug-ins and extensions can help you automate tasks, customize workflows, create specialized professional effects, and more.

Adobe downloads
Visit www.adobe.com/go/downloads to find free updates, tryouts, and other useful software.

Adobe Labs
Adobe Labs at www.adobe.com/go/labs gives you the opportunity to experience and evaluate new and emerging technologies and products from Adobe.

Adobe TV

Extras
The installation disc contains various extras to help you make the most of your Adobe software. Some extras are installed on your computer during the setup process; others are located on the disc.

To view the extras installed during the setup process, navigate to the application folder on your computer.

- Windows: [startup drive]/Program Files\Adobe\[Adobe application]
- Mac OS: [startup drive]/Applications/[Adobe application]
Chapter 2: The Flash Catalyst workflow

Adobe Flash Catalyst CS5 is a design tool for rapidly creating application interfaces and interactive content without coding. Examples include interactive ads, product guides, design portfolios, and user interfaces. While there is not a single, prescribed workflow for creating all projects in Flash Catalyst, there are tasks common to many basic projects. Here is an overview to get you up and running quickly:

**General workflows**

There are two main types of Flash Catalyst applications. These applications include micro sites and data-centric applications.

In this document, micro site is an application that is complete when published in Flash Catalyst. No additional development is required. A data-centric application requires additional development, such as integrating components with external data or web services. A Flex developer completes the development using Adobe Flash Builder.

The workflows for designing micro sites and data-centric applications are similar.

---

**Micro site workflow**

1. Plan
2. Create and acquire assets
3. Bring assets into Flash Catalyst
4. Create pages and states
5. Create components
6. Define interactions
7. Create transitions
8. Publish to the web or desktop

**Data-centric designer/developer workflow**

1. Plan
2. Create and acquire assets
3. Bring assets into Flash Catalyst
4. Create pages and states
5. Create components
6. Define interactions
7. Create transitions
8. Connect to data and web services
9. Publish to the web or desktop
Workflow steps
Follow these general workflow steps when creating micro sites and data-centric applications with Flash Catalyst.

**Plan the application**  Start with a detailed project specification. This specification describes each page or screen, the artwork and interactive components on each page, user navigation, and the different states of each component. The specification also describes any data list components used to retrieve and display external data.

**Create or acquire artwork, video, and sound**  Create the artwork, video, and sound for the application. Create a layered design document or composition in Adobe Illustrator, Photoshop, or Fireworks.

**Bring in artwork, video, and sound**  Start Flash Catalyst. Bring the layered artwork into Flash Catalyst. You can also import individual graphic files or create simple graphics using the built-in vector drawing tools. Import additional assets, such as video, sound, and SWF content. For data-centric components, such as a data list, import a representative sample of the data (text or images). For more information, see “Importing artwork” on page 6.

_after importing or creating artwork in Flash Catalyst, you can launch and edit artwork in Illustrator or Photoshop, and then return the edited artwork to Flash Catalyst. Round-trip editing extends the graphic drawing and editing capabilities of Flash Catalyst and improves the iterative design process. For more information, see “Round-trip editing” on page 57._

**Create and modify page states**  Create pages according to the project specification. For more information, see “Defining structure with pages and states” on page 14.

**Create interactive components and define component states**  Convert artwork to ready-made components (buttons, scroll bars, data lists, and so on). Use the Wireframe Components panel to quickly add common components with a generic appearance. Create custom components for behaviors that you can’t capture with the built-in components. For more information, see “Interactive components” on page 24.

For data-centric applications, use design-time data to design data list components. Design-time data allows the use of dummy content, such as sample database records or bitmap images, without having to actually connect to a back-end system. A Flex developer can replace the design-time data with real data from a database or web service. For more information on using Design-time data, see “Creating scrolling images, panels, and lists” on page 40.

Components can have multiple states, such as the Up, Over, Down, and Disabled states of a button. Create or modify the different states of each interactive component, according to your project specification

*Note:* _The steps of creating page states and creating interactive components are interchangeable. Some designers prefer to create all interactive components first, and then add those components to pages and states._

**Define interactions and transitions**  Add interactions that define what happens as users interact with the application. For example, you can add interactions that transition from one page or component state to another when a user clicks a button. You can also add interactions that play animation, control video playback, or open an URL. Use the Timelines panel to add and modify smooth animated transitions between pages and component states. For more information on interactions, see “Interactions and action sequences” on page 30. For more information on transitions, see “Transitions and the timeline” on page 35.

**Test and publish the project**  When you finish creating a micro site, you can publish the final project as a web or desktop application. For more information, see “Preview and publish” on page 64.

**Share the project with a Flex developer**  Save a data-centric Flash Catalyst project file (FXP) for further development in Adobe Flash Builder. Export the Flash Catalyst project library. Exporting a library package creates a single file containing every library item in the project. The package is saved as an FXPL file. For more information on exporting a Flash Catalyst library, see “Extending Flash Catalyst projects using Flash Builder” on page 67.
Start a new Flash Catalyst project

You can start a new project in two ways:

- Start with a blank artboard and build your application. This approach is useful for rapid wire framing of user interfaces. Catalyst provides wireframe components, drawing tools, and the ability to import various media to rapidly prototype an interface.

- Import a completed design document as layered artwork created in Adobe Photoshop, Illustrator, or an exported design from Fireworks. Using this approach, you can design in your favorite Adobe Creative Suite application and quickly convert the artwork into a functioning interactive application.

Start a project with a blank artboard:

1. Start Flash Catalyst. In the Create New Project section of the Welcome screen, choose Adobe Flash Catalyst Project.
   
   *Note: If you already have a project open, choose File > New Project to begin a new blank project.*

2. In the New Project dialog box, name the project, enter values for the size and color of the artboard, and click OK.
   You now have a new project with a blank artboard. By default, the Design workspace is open. You can build your application by importing artwork, adding pages, creating components, and adding interactions and transitions.

   *Note: You can change the artboard values later by choosing Modify > Artboard Settings.*

Start a project by importing artwork in a layered design document:

1. Start Flash Catalyst.

2. In the Create New Project from Design File section of the Welcome screen, choose the type of file you want to import. Options include: Adobe Illustrator AI File, Adobe Photoshop PSD File, FXG File (FXG files can be exported from Adobe Fireworks, as well as other applications).

   *Note: If you already have a project open, choose File > Import > <File Type>.*

   All artwork in the design document is added to the new Flash Catalyst project. The Layers panel reflects the layer structure from the imported document, preserving the integrity of your original design.

   You can now build your application by adding pages, creating components, and adding interactions and transitions.

   For more information, see “Importing artwork” on page 6.
Chapter 3: Importing artwork

There are several ways to get your artwork into Flash Catalyst.

- Import a layered design document created in Adobe Photoshop or Adobe Illustrator.  
  \textbf{Note: Flash Catalyst only imports design documents that are 40 MB or less.}
- Import a layered FXG file. You can export an FXG file from Adobe Fireworks and other Adobe Creative Suite applications.
- Import one or more bitmap images.
- Copy and paste graphics into the Flash Catalyst artboard.
- Import a SWF file.
- Import a Flash Catalyst library package.

When you import artwork from Illustrator CS5 into Flash Catalyst CS5, the layer structure remains intact and art can continue to be edited in Illustrator.

\textbf{Import Adobe Illustrator files}

You can start a new Flash Catalyst project by importing an Illustrator file.

1. Start Flash Catalyst.
2. In the Create New Project From Design File section of the Welcome screen, choose From Adobe Illustrator AI File.
   \textit{If Flash Catalyst is already running, choose File > New Project From Design Comp. You can have only one project open at a time.}
3. Browse to the file you want to import, select it, and click Open.
   The Illustrator Import Options dialog box includes artboard settings and fidelity options. You can choose to import non-visible layers and include unused symbols.
Note: Choosing Import Non-Visible Layers imports all layers, including layers that are hidden in the Illustrator file. Choosing Include Unused Symbols imports the graphic symbols that ship with Illustrator and the symbols you create.

4 Specify a size and color for the artboard. Select import fidelity options and click OK.

![Illustrator Import Options dialog box](image)

The Illustrator file converts to the FXG format automatically, and then imports into a new Flash Catalyst project. If the Illustrator file includes a single artboard, all artwork is placed in the same Flash Catalyst page state. If the Illustrator file includes multiple artboards, the artwork in each artboard is placed in a separate Flash Catalyst page state.

You can copy and paste individual pieces of artwork from Illustrator into the Flash Catalyst artboard. The Illustrator Import Fidelity Options also appear when you copy and paste artwork.

Note: Objects outside the Illustrator artboard are discarded when you import or copy and paste artwork into Flash Catalyst.

Illustrator symbols import as Optimized Graphics. If your Illustrator file includes multiple instances of the same symbol, then your Flash Catalyst document will include multiple instances of the same optimized graphic. In Flash Catalyst, it is a best practice to use one instance of an object and then share that object to other states. You can remove all but one instance of the optimized graphic, share the same instance to other states, and then apply different properties in each state. To convert the optimized graphic into a Flash Catalyst component, you must first break it apart by choosing Modify > Break Apart Graphic.

**Import Adobe Photoshop files**

You can start a new Flash Catalyst project by importing a Photoshop file.

1 Start Flash Catalyst.

2 In the Create New Project From Design File section of the Welcome screen, choose From Adobe Photoshop PSD File. If Flash Catalyst is already running, choose File > New Project From Design Comp. You can have only one project open at a time.

3 Browse to the file you want to import, select it, and click Open.

The Photoshop Import Options dialog box includes artboard settings and fidelity options. You can also choose to import non-visible layers.

Note: Choosing Import Non-Visible Layers imports all layers, including layers that are hidden in the Photoshop file.
4 Specify a size and color for the artboard. Select import fidelity options and click OK.

![Photoshop Import Options dialog box]

*Click Advanced in the Photoshop Import Options dialog box to specify exactly which layers to import. You can select and deselect layers to import, regardless of their visibility in Photoshop.*

**Import FXG files**

Flash Catalyst imports artwork in the FXG file format.

1 Start Flash Catalyst.

2 In the Create New Project From Design File section of the Welcome screen, choose FXG File.

   *If Flash Catalyst is already running, choose File > New Project From Design Comp. You can have only one project open at a time.*

3 Browse to the file you want to import, select it, and click Open.

For information on exporting an FXG file from Fireworks, see Export FXG files.

**Import bitmap images**

Flash Catalyst accepts bitmap images with the PNG, GIF, JPG, JPEG, and JPE filename extensions.

1 Choose File > Import > Image.

2 Browse to locate the file, select it, and choose Open.

   - When you import a single image file, it is placed in the project library and an instance is placed in the artboard in the current state. A new layer for the object is added in the Layers panel.
   - When you import multiple image files, they are placed in the project library. No image is added the artboard. To add an instance of the image to the artboard, drag it from the Library panel to the artboard.

**Import SWF files**

1 Choose File > Import > SWF File.
2  Browse to locate the file, select it, and choose Open.
   - When you import a single SWF file, it is placed in the project library and an instance is placed in the artboard in the current state. A new layer for the object is added in the Layers panel.
   - When you import multiple SWF files, they are placed in the project library. No SWF file is added the artboard. To add an instance of the SWF file to the artboard, drag it from the Library panel to the artboard.
   - You cannot preview a SWF file in Flash Catalyst Library panel. To preview the SWF file, run the project by choosing File > Run Project.
   - Use interactions and effects in Flash Catalyst to control the playback of SWF files. You can also play or stop a SWF file at a specific frame. For more information, see “Interactions and action sequences” on page 30.
   - Only SWF content written in ActionScript 3.0 and published using Adobe Flash Professional is controllable in Flash Catalyst.
   - There is no direct integration between Flash Catalyst and Flash Professional. Edit the SWF file in Flash Professional, republish, and import the new file into Flash Catalyst. Use the Source link in the Properties panel to swap the old SWF file for the new one.

**Import a Flash Catalyst library package**

For information on importing artwork in a library package, see “Export and import a library package” on page 23.

**Import fidelity considerations**

When you import from Illustrator and Photoshop, you specify fidelity options that control how Flash Catalyst imports your artwork. It is helpful to know which attributes are supported in Flash Catalyst, and when to flatten or rasterize artwork before importing.
Chapter 4: User interface

The Flash Catalyst CS5 user interface has two workspaces. These workspaces include Design and Code. Use the Workspaces pop-up menu to change between workspaces.

Design workspace

The Design workspace shows a graphical representation of your pages and states. This workspace includes the panels and tools used for creating and editing projects. Use the Hand tool to grab and pan the artboard as an alternative to scrolling. Use the Zoom tool or Magnification menu to change the view from between 25% and 800% of actual size. Use the magnifying glass to zoom into a specific part of the artboard (Alt-click (Windows) or Option-click (Mac OS) to zoom out). When you enter a term in the Search box, the Adobe Community Help client appears. It gives you access to online Help and community resources.

Artboard  The artboard represents what users see when they view the published application. The artboard is where you place artwork, interactive components, and other objects that make up the application interface. It has rulers, grids, and guides for positioning and snapping elements. These features are available in the View menu. Use the Modify menu to align, group, and arrange (front to back) the objects on the artboard.
Using Flash Catalyst

User Interface

Breadcrumbs bar The Breadcrumbs bar, located directly above the artboard, tracks where you are as you work in Flash Catalyst. For example, when you open a component, you can use the Breadcrumbs bar to quickly close the component and return to the main artboard.

Pages/States panel The Pages/States panel displays a thumbnail for each page in the application. It shows the different states for any component you select. You can duplicate, remove, add, and rename pages and component states according to your project plan. For more information, see “Defining structure with pages and states” on page 14.

Tools panel The Tools panel includes tools for creating, selecting, and transforming objects, including simple lines, shapes, and text.

Layers panel The Layers panel is an organized collection of the objects in the application (artwork, components, video, and so on). When you import a design document created in Illustrator, Photoshop, or Fireworks, Adobe Flash Catalyst preserves the original layer structure. As you add pages and component states to the application, you use the Layers panel to show or hide objects in each state. For more information, see “Layers” on page 19.

Library panel The Library displays the entire list of graphics and other media available in the project, including your project skins and components. For more information, see “Library” on page 22.

Wireframe Components panel Wireframe components are ready-to-use interactive components with a simple default appearance. You can drag these components to the artboard and use them “as is” or modify them to fit the appearance of your application. For more information, see “Interactive components” on page 24.

Interactions panel Add interactions that define what happens as users interact with the application. For example, you can add interactions that transition from one page or component state to another when a user clicks a button. You can also add interactions that play animation, control video playback, or open an URL. For more information, see “Interactions and action sequences” on page 30 “Transitions and the timeline” on page 35.

Timelines panel The Timelines panel provides controls for creating and editing transitions and action sequences. You can also use the Timelines panel to control the playback of video and SWF content, and to add sound effects. For more information, see “Transitions and the timeline” on page 35.

Design-Time Data panel After creating a data list component, use the Design-Time Data panel to control which data (images and text) appear in the data list. For more information, see “Creating scrolling images, panels, and lists” on page 40.

Properties panel Use the Properties panel to edit the properties for selected objects, such as graphics, text, and components. The available properties change as you select different objects in the artboard, Layers panel, or Timelines panel.

Heads Up Display (HUD) The HUD gives quick access to common commands related to the current action or currently selected object. It shows some of the key actions you can perform on the selected objects. For example, the HUD appears when you select artwork on the artboard, giving you the choice of converting the artwork to a component. Use the HUD to quickly create components.
The HUD displays context-appropriate commands.

- If you don’t see the HUD when you select an object, select Window > HUD.
- When converting objects to components, the HUD displays a message if additional steps are required to complete the component.
- All of the functionality in the HUD is also available in the main menu. For example, you can choose Modify > Convert Artwork To Component.

Use the HUD to quickly:

- Convert artwork to components or component parts.
- Edit the parts and states of a component.
- Optimize graphics elements.
- Make the parts of a component the same in all states or copy changes from one state to another.

For more information on using the HUD, see “Interactive components” on page 24, “Creating scrolling images, panels, and lists” on page 40, “Creating shapes, lines, and text” on page 45.

**Code workspace**

The Code workspace shows the underlying application code. This code is generated automatically as you work in Flash Catalyst.

The applications you build in Flash Catalyst are build on the Flex framework. Flex is an open source framework for building and deploying applications that run in all major browsers and operating systems. MXML is the language developers use to define the layout, appearance, and behaviors in Flex. ActionScript 3.0 is the language used to define the client-side application logic. When you publish a Flash Catalyst project, your MXML and ActionScript are compiled together as a SWF file.
Viewing the MXML code gives designers the opportunity to understand how the application is programmed. The Code workspace is read-only. To edit the code, open the project in Adobe Flash Builder. For more information, see “Extending Flash Catalyst projects using Flash Builder” on page 67.

**Code workspace**

- **Code panel** Shows the MXML code in the Code panel.
- **Problems panel** Shows any errors in the current MXML code.

> You can double-click an error in the Problems panel to locate the error in the code.

- **Project Navigator panel** Shows the Flex project directory structure and files being created as you design your project in Flash Catalyst.
Chapter 5: Defining structure with pages and states

Most interactive projects and applications are designed to present information in more than one view, or page. The different views a user sees when navigating through an interactive project—or when clicking on an interactive component (such as a button) inside of your project—are called "states" in Flash Catalyst. There are two types of states:

**Page states.** A simple interactive ad might have one view that contains a sale offer, and another view that contains pricing details. Each view can be defined as a page state. Think of page states as forming the top level structure of your project or application.

*This interactive ad has 3 views defined as Page states. You can control what displays on any Page state by turning layers on and off in the layers panel.*
USING FLASH CATALYST

Defining structure with pages and states

Click a state in the Pages/states panel to select it; then use the layers panel to determine what displays on the selected state.

**Component states.** Continuing with the same example above, a sale offer page may include interactive button components for navigating, or the pricing details page may have a scrolling list component. These interactive components can also have states. "Component states" define the look and feel of an object (for example, a button) at a certain point in time; usually based on a mouse event or other user interaction.

Add, duplicate, and delete pages and states

All Flash Catalyst pages and component states are created, modified, and managed in the Pages/States panel. A new Flash Catalyst project begins with one page state.
Note: If you import an Illustrator file with multiple artboards, each artboard is added to a separate page state.

- To add a new page based on an existing page, select the existing page in the Pages/States panel and click Duplicate State.
- To create a new blank page (one in which all layers are hidden and no objects are present), click New Blank State.
- To delete a page, select it in the Pages/States panel and click the Delete button (trash can).

When you duplicate a state, you are not duplicating objects. The objects persist across states. You can show or hide the objects in each state using the Layers panel.

An application or custom component can have no more than 20 states. Adding too many page states can slow performance. If the application requires more than 20 states, you can encapsulate them in custom components. For example, you can encapsulate menu bars and other components that appear on multiple pages.

In addition to improving application performance, there are other advantages to creating your different application views using custom components.

- A custom component is more versatile than a page state. It can have a unique set of properties (size, position, opacity) in each page or parent component where it’s used.
- A custom component can appear to the viewer as if they are viewing another page or screen in the application.
- Components can be nested inside other components. Nesting components makes it possible to create a more efficient application with many states or views.
- Editing a component in Edit-In-Place updates the component throughout the application.

Note: Some components have a fixed set of states, such as the Up, Over, Down, and Disabled states of a button. You cannot duplicate or delete these component states, but you can hide them by hiding all layers for the selected state.

See the following for more information on creating and editing components:

“Interactive components” on page 24

Name pages and states

Consider the following when naming pages and component states:

- To rename a page or component state, double-click its name in the Pages/States panel, type a new name, and press Enter (Windows) or Return (Mac OS).
- State names must begin with a letter.
- State names cannot contain spaces.
- State names cannot contain special characters: @!#$%^&*().

Navigate between pages and states

- To view the contents of a page, select it in the Pages/State panel. The artboard shows all visible objects in the selected page.
- To view the different states of a component, double-click the component in the artboard to enter Edit-In-Place mode. When you edit a component in place, the Pages/States panel updates to show the states of the component.

Note: When a component is in Edit-In-Place mode, the Layers panel splits into sections. It shows layers for both the project and any components you have open. You can drag objects from the main application layers into the component.
Show and Hide artwork in pages and states

When you import a design document, the artwork is added to a page state in Flash Catalyst.

To add additional objects to a state, do one of the following:

- Import new artwork.
- Drag assets from the Library panel to the artboard.
- Create new objects with the Flash Catalyst drawing tools.

For more information on the drawing tools, see “Creating shapes, lines, and text” on page 45.

When you add objects to a page or component state, they are present. They exist in that state. When an object is present, it can be made visible or hidden. The following information helps identify the presence and visibility of objects in the current state using the Layers panel:

- **Present and visible** The name of the object is listed using dark text (present), and the eyeball icon is dark (visible).
- **Present and hidden** The name of the object is listed using dark text (present), but there is no eyeball icon showing (hidden). If the eyeball appears dimmed, the object’s visibility is on but its parent layer is hidden. When a parent layer or group is hidden, its children are hidden automatically.
- **Not present** The name of the object is listed using dimmed text (not present). The object is not present in the current state, but it does exist in one or more other states of the application.

Use the following techniques to display or hide objects in a state:

- Turn the eyeball icon on or off to show or hide an object.
  
  *The eyeball icon is a toggle. Click the Show/Hide column (far left column) beside an object in the Layers panel to toggle its visibility.*

- Turn off the eyeball icon for a parent layer or group to hide all of its children.

- Select an object and press Delete to remove the object from the current state. If the object exists in other states, its name turns dim in the Layers panel. If the object does not exist in any other states, it disappears from the Layers panel.

- Turn on the eyeball icon to share an object to the current state when its name is dimmed.

- Select an object and click the Delete button (trash can) in the Layers panel to remove it from all states and the Layers panel.

*Note: You can make an object appear invisible or partially transparent by changing its Opacity value in the Properties panel.*

For more information on the Layers panel, see “Layers” on page 19.
Share objects between pages and states

A single object can appear in multiple states. That object can have a different set of properties, such as size, position, color, and transparency in each state where it exists. In most cases, when you modify an object, those changes apply only to the object in the current state. Once you position and modify an object to your liking, you can quickly share that object, along with its properties, to other states.

This technique makes it possible to create smooth transitions from one state to the next. For example, you can create the effect of an object fading in or out or morphing from one shape or position to another.

- To share an object to other states, select the object and choose States > Share To State. Select the states to which you want to share the object.
- To remove an object from a specific state, select the object in one state and choose States > Remove From State. Choose the state from which you want the object removed.
- To make an object the same in all states, modify its properties, and then choose States > Make Same In All Other States.

**Note:** Some edits or changes apply to all states. Any change that affects the application hierarchy is shared across all states automatically. For example, if you group objects or convert objects to components, the change applies to all states. If you edit a component using Edit-In-Place mode, you edit the component definition in the project library. The changes apply to all instances of the component in all states.

For more information on components, see “Set component properties” on page 25.

For more information on transitions, see “Transitions and the timeline” on page 35.
Chapter 6: Layers

The Flash Catalyst CS5 Layers panel serves a few primary functions. It provides an organized structure for viewing and managing every object in the application (or a component that you have open for editing). It also indicates which of those objects are present and visible in the current state. The current page or state is indicated in the Pages/States panel. See “Show and Hide artwork in pages and states” on page 17.

Organize a project using layers

The Layers panel shows every object in the application using a collection of stacked rows. Rows can represent layers, sublayers, objects (images, shapes, text, components), and groups (grouped objects).

An eyeball icon to the left of a row indicates that objects are visible in the current page or state. If an eyeball is dimmed, it means that the row is visible, but its parent layer or group is hidden in the current state. Objects that do not exist in the current state are dimmed with no eyeball. Objects that do exist but are hidden in the current state are regular text with no eyeball. A padlock icon in the second column of a row means that it is locked. A locked layer can be viewed but not edited. Locking layers prevents content from being selected or moved accidentally. The target layer for new content that you add to the artboard is shaded light blue. The currently selected row/object is a slightly darker shade of blue. A small blue square means that the row includes a selected object. You can follow the blue squares as you drill down to find the selected item.

- To expand or collapse a layer or group, click the small arrow.
- To rename the row representing a layer, object, or group, double-click the current name, type a new name, and press Enter (Windows) or Return (Mac OS).
- To add a new layer, click the Create New Layer or Create New Sublayer button.
- You can delete a layer, object, or group from all states in the application. Select its row and click the Delete button (trash can) in the Layers panel. The object is removed from every state.
Flash Catalyst Layer panel terminology
The following list summarizes how Flash Catalyst layer terminology compares to layer terminology in Illustrator, Photoshop, and Fireworks.

- A Flash Catalyst Layer is the same as an Illustrator Layer, a Photoshop Layer Group, and a Fireworks Layer Folder.
- A Flash Catalyst Object is the same as an Illustrator Object, a Photoshop Layer, and a Fireworks Layer.

Selecting objects in the Layers panel
You can select layers, objects, or groups (grouped objects) in the artboard or in the Layers panel.

- To select a single object, click its row in the Layers panel.
  
  Note: Use the Select or Direct select tool to select an object or group in the artboard.

- Shift+click to select a contiguous range of objects in the Layers panel.

- To select non-contiguous objects in the Layers panel, Control+click (Windows) or Command+click (Mac) two or more objects.
  
  Note: Shift+click to select multiple objects in the artboard.

- Selecting a layer in the Layers panel selects the layer and all of its children.

- Selecting a group in the Layers panel selects the group as a single object. The group’s Properties are active in the Properties panel.

- To select the individual children in a group, select their individual rows in the Layers panel.
  
  Note: Use the Direct Select tool to select the children of a group in the artboard.

Manage artwork using layers
When you import a design document created in Adobe Illustrator, Photoshop, or Fireworks (FXG), Flash Catalyst maintains the integrity of the original design. With your artwork organized into layers, you can begin creating the different pages, components, and component states for the application.

Use the Layers panel to determine which artwork is visible, hidden, or present on each page.

- Click the eyeball icon to hide or show an object in the current state. When you hide an object, it is still present in the current state, but not visible.

- To remove an object from the current state, select it and press Delete. The object is no longer present in the current state. If the item still exists in another state, the item’s name appears dimmed in the Layers panel. You can return it to the current state by clicking its Show/Hide button.

- You can use the artwork in multiple layers to create interactive components, such as a button or scroll bar. Components can have multiple states, such as up, over, down, and disabled. When you edit a component in Edit-In-Place, the Layers panel expands to show the objects in the selected component. Use the Layers panel to hide or show artwork in each component state.

- As you modify the artwork in a page or component state, each object’s size, position, and visual attributes are remembered for each state. You can have the same object appear differently from one state to another. For more information, see “Defining structure with pages and states” on page 14.
• To change the stacking order of objects in the application, you can drag rows up or down in the Layers panel. You can also change the stacking order of objects within a layer or group. Drag the object row or select the object and choose Modify > Arrange > Bring To Front, Bring Forward, Send Backward, or Send To Back.

**Note:** The stacking order of layers is constant across all states. Unlike object properties, you can’t have a different stacking order in different states.

See the following for more information on components and editing objects.

“Edit-In-Place” on page 27

“Creating shapes, lines, and text” on page 45
Chapter 7: Library

The Library panel is a storage area for the reusable assets that you add to a Flash Catalyst CS5 project.

Objects in the Library panel include:

- **Components**: Interactive objects that you create by converting artwork into components or by modifying the wireframe components to create custom skins.
- **Images**: Bitmap files (PNG, GIF, JPG, JPE, JPEG) and SWF content
- **Media**: Video and sound files (FLV/F4V files, mp3)
- **Optimized Graphics**: In an optimized graphic file, all MXML information (vector, stroke, path, fill, and so on) is kept separately in an FXG file. Optimized graphics are created when you convert artwork to an optimized graphic using the Optimize Artwork options in the HUD or Modify menu. When you import an Illustrator file containing symbols, the symbols are automatically converted to optimized graphics. For more information, see “Optimizing graphics” on page 55.

Note: When you import an Illustrator, Photoshop, or FXG file, its bitmap images are stored in a separate subfolder within the Images category.

Manage and place artwork from the Library panel

After importing artwork or creating components, you can reuse these objects in other parts of your project. When you drag a library item to the artboard, you are adding an instance of the library asset to the application. A new object is created in the target layer folder in the Layers panel. Best practice is to give a descriptive name to each object in the Layers panel. That instance of the asset persists across the other states in the application. After adding the asset to the application, you can share it to other states. You can show and hide the asset, or delete it from a specific state. For more information, see “Share objects between pages and states” on page 18.

If you drag another copy of the same asset to the artboard, you have two instances of the same asset in the application. It appears twice in the Layers panel. In most cases, you don’t want to add two instances of the same asset. If you want the same asset to appear in more than one state, add one instance and share it to other states.
Note: If you are editing a component in Edit-In-Place mode, the asset is added to the component, not the application. If you want the asset to appear in the component and in the main application, you can use two instances of the asset. For more information, see “Edit-In-Place” on page 27.

- To rename an item in the Library panel, double-click its name, type a new name, and press Enter (Windows) or Return (Mac OS).
- To preview an image in the Library panel, select it. A preview appears at the top of the panel. To preview an audio or video clip in the Library panel, select it and click the Play button that appears.
- To delete an item from the project, select it in the Library panel, and click the Delete button (trash can). Deleting an item from the Library removes all instances of the item from the project.

Note: The Layers and Library panels are not linked. Renaming an instance of an item in the layers panel does not affect the original item definition name in the Library panel. When you change the properties of a library item in one state, you are not affecting the properties of the asset in other states. However, if you edit a component in Edit-In-Place mode, you edit the item definition in the project library. Editing the item definition changes every instance of the item in all states.

Export and import a library package

The Library panel facilitates collaboration among the design team. Exporting a library package creates a single package containing all of the library items in the project. The package is saved as an FXPL file. FXPL packages can be used to distribute your project assets to teams. Assets can include logos, video content, components, and so on. Sharing the FXPL reduces duplication of work.

If you are creating a data-centric application, your FXPL document can be imported into Flash Builder by a Flex developer.

- To export a library, click the Export Library Package button. Specify a name and location for the file, and click Save.
- To import a library, click the Import Library Package button. Browse to locate the file, select it, and click Open.

Note: Before you export the library package, be sure that your assets, including components, have descriptive names. No developer wants to receive a library package filled with assets named, button1, button2, and so on.

For more information, see “Extending Flash Catalyst projects using Flash Builder” on page 67.
Chapter 8: Interactive components

Interactive components are the building blocks of any Flash Catalyst project. An interactive component consists of artwork, plus any interactivity associated with it. Click the tabs in the interactive piece below to see examples of the various components.

Flash Catalyst provides a collection of components with predefined interactivity. For example, to enable creation of a hover or rollover effect, the Button component contains four built-in states: up, over, down, and disabled. The appearance of the button in each of these four states can be edited independently to create the desired effect.

In general, you create components in two ways:

- Convert static artwork (imported or drawn) into a component. Convert artwork by using options in the Heads Up Display (HUD) or by choosing Modify > Convert Artwork To Component. You can choose from a list of built-in component types or design a custom/generic component.

- Add a wireframe component with a generic appearance from the Wireframe Components panel.

After creating a component, you can add interactions that define the desired behavior when a user interacts with that component. For more information on interactions, see "Interactions and action sequences" on page 30.
Note: Data lists, a complex type of component, are discussed separately. For more information on data lists, see: “Creating scrolling images, panels, and lists” on page 40.

Create a component from custom artwork

Most components are made from a collection of parts. For example, a button can have a background design and a label. A scroll bar includes a track, thumb, and can also include scroll arrows.

When you convert artwork to a component, Flash Catalyst groups the selected objects as a new component. The component is added to the project library and appears in the Components category in the Library panel. Flash Catalyst automatically replaces your artwork with an instance of the component. The component is now part of your application, and you can share that same instance of the component to other states. The instance of the component also appears in the Layers panel.

To convert artwork to a component:

1. Using the Layers panel or in the artboard, select the objects you want to convert to a component.
2. In the HUD, click Convert Artwork To Component and choose a component type. If you select from one of the built-in components, the states are defined automatically. If you select Custom/Generic Component, you can define its states the same way you define page states.

Note: Some components have special requirements and do not function properly until you define their required parts. For example a Data List must have a repeating item, and a scroll bar must have a track and thumb. If the component has special requirements, a message appears in the HUD with instructions on how to complete the component. The commands to create and edit components are also available from the Modify menu.

- To make a component based on an existing one, right-click the component in the Library panel and choose Duplicate.
- To rename a component in the Library panel, right-click the component and choose Rename (or double-click the component). Type a new name and press Enter (Windows) or Return (Mac OS). Component names must contain only letters, numbers, or the underscore character. They must be unique to the project and begin only with a letter or underscore.

If you create a component from artwork that is shared in multiple states, you lose stateful properties or transition effects associated with that item. It is a good practice to define component structure before building transitions. If you plan to convert artwork to components, avoid sharing that artwork to other states until you have created your components.

Set component properties

Each component can appear in more than one state and can have its own unique set of properties in each state. For example, a button can be enabled on page 1, but disabled on page 2. Other examples of component properties are opacity, filters, and rotation.

When a component is disabled in the Properties panel, its disabled state is shown. Design the disabled state to appear selected. Then disable the button in its target state. For example, if a navigation button is labeled 1 and clicking the button takes you to page 1, then disable the button in page 1. When you are in page 1, the button is disabled and appears selected.
To change component properties, select the component in the artboard, and modify its properties in the Properties panel. When you apply components properties, the changes only apply to the current state. You are not editing the component. To apply the same properties to the same component in all other states, select the component and choose States > Make Same In All Other States.

**Note:** You cannot use the Properties panel to change the height and width properties of a component with a custom skin; however, you can use the Properties panel to change the height and width of wireframe components. For more information, see Resizing Flash Catalyst components with custom skins.

To resize a component, or make other changes that apply to all instances of the component, edit the component using Edit-In-Place. When you edit a component using Edit-In-Place, the changes you make apply to all instances in all states. See “Edit-In-Place” on page 27.

You can edit the properties for each instance of a component

Component properties include:

**Accepts Mouse Events** Makes an object appear visible to the mouse. If you deselect Accepts Mouse Events, mouse events pass through to the next item in the layer order. Changing this setting does not change how the component appears.

**Transparency Accepts Mouse** Areas within the component or group bounds that are transparent respond to mouse rollovers and clicks. The mouse-responsive area is always a rectangle (as opposed to following the contours of the opaque pixels). In most cases, objects underneath the transparent area no longer respond to mouse rollovers and clicks, because the transparent group/component on top is “blocking” them.
Suppose you have a text list with a background image spanning the entire list area. In order for the list to be visible, individual list items (Repeated Items) must have a transparent background. Check “Transparency accepts mouse” so that the user can click anywhere within the list item to select it (not just on the opaque text.)

**Tab Index**  Controls the order of items when pressing tab to move the keyboard focus. Lower numbers place the item earlier in the sequence. The -1 indicates a default order based on the Layer panel order.

**Tab To Focus**  Means that it is possible to give the component keyboard focus by tabbing to it. If Tab To Focus is deselected, pressing tab does not give the component keyboard focus. It must be clicked to get focus.

**Tooltip**  Enter text to display as a tool tip when the user interacts with the component.

**Display As Password**  Displays the text field’s contents as a series of asterisks.

**Editable**  The text in a Text Input can be selected, but cannot be edited (when deselected).

**Max Characters**  Automatically sizes a Text Input control to accommodate a specific number of characters. This property is only applicable for a wireframe text input that has not been manually resized.

**Selected Index**  The item selected in a list by default. The first item is 0, the second items is 1, and so on. A value of -1 means nothing is selected.

**Focus Ring**  The color of the halo or highlight shown on a control when it has the keyboard focus.

**Hand Cursor**  Rolling over the object with the mouse shows a pointing hand.

**Accessible Text**  The text describing the object for screen reader technologies.

**Radio Button Group**  Only one radio button within a group can be selected. Radio buttons are in the same group if this property is set to the same name. Radio buttons are also in the same group if they are grouped, inside the same component, or at the application level.

**Page Size**  How far the thumb moves in a scrollbar when clicking in the track.

**Step Size**  How far the thumb moves when clicking the arrows. In a slider, Step Size controls how far the thumb moves when pressing the arrow keys.

**Snap Interval**  Forces the thumb in a scrollbar to snap in increments rather than moving smoothly. Page Size and Step Size are always forced to be multiples of the Snap Interval.

See the following for more information on setting object properties:

“Modify drawing and text properties” on page 47

---

**Edit-In-Place**

After adding a component to the artboard, you can edit the component by using Edit-In-Place and modify its individual parts. When you edit component parts using Edit-In-Place, the changes apply to all instances of the component in all states. Any properties that you have applied in each state, such as opacity, are preserved.

Select the component you want to edit. In the HUD, choose the state you want to edit, or click Edit Parts or Edit Appearance.

**Note:** You can also double-click a component to enter Edit-In-Place or choose Modify > Edit Component.

Flash Catalyst changes to Edit-In-Place mode, indicated by a dimmed artboard. The different states of the component appear in the Pages/States panel. The Breadcrumbs bar shows the name of the component you have open.
The Layers panel divides into two sections. One section shows the layers for the component you are editing. The other section (below it) shows the main application layers. You can drag objects between the main application and the component you are editing.

2 Use the Layers panel to hide or show artwork in each state.

When a component is in Edit-In-Place:

- You can duplicate states, add new blank states, or delete states in the Pages/States panel.
- You can modify the artwork in each state by using the drawing tools and Properties panel. For example, you can change the size, stroke, fill, and opacity of a shape or other parts of the component.

3 Exit Edit-In-Place mode by pressing Escape or clicking the name of the application in the Breadcrumb bar above the artboard. You can also click the dimmed area in the artboard or choose Modify > Edit Editing.

Moving the parts of a component while in Edit-In-Place can change the size of the component. If you have Auto Size Component Bounds selected in the Modify menu, the component bounds resize automatically in all states. When Auto Size Component Bounds is turned off, you can select Clip To Component Bounds in the Modify menu. Clip To Component Bounds clips any parts that extend beyond the component.

## Add a wireframe component

1 In the Pages/States panel, select the page in which to add the component.
2 In the Layers panel, select the target layer in which to add the component.
3 In the Wireframe Components panel, drag a component to the artboard.
4 Use the Select tool, in the Tools panel, to position the component in the artboard.
5 Use the Properties panel to set component properties, such as size.

You can use the wireframe components as is, or double-click a component to edit its parts. As soon as you edit a wireframe component, you create a custom skin. The new component is added to the Components category in the Library panel.

**Note:** You cannot use the Properties panel to change the height and width properties of a component with a custom skin.
Interactive components

You can determine if a component is a generic wireframe component or a component with a custom skin. Select the component in the artboard. View the name of its skin in the Common section of the Properties panel. Wireframe components have the skin name “Wireframe.” Custom components have a custom skin name that is derived from their component name.

You can place wireframe components inside a custom component that you have open for editing.
Chapter 9: Interactions and action sequences

Interactions are events that occur in response to some user action, such as the click of a button. For example, the application can display a new page when a user clicks a button. In this case, you define an interaction triggered by clicking that button.

With an interactive component button selected, you can use the Interactions panel to connect your buttons to view states in your project.

Flash Catalyst CS5 has many built-in interactions that you can quickly add to components or grouped objects, including:

- Transition from one page or component state to another
- Trigger an action sequence, such as playing a sound, moving an object, or playing an animation
- Go to a URL
- Play, pause, or stop a video clip
Add interactions

You can add interactions to components or grouped artwork. Use groups to hold interactions when you don’t need a reusable component.

1. Select a component or group.
2. Click Add Interaction in the Interactions panel.
3. Choose an event that triggers the interaction, such as On Click or On Roll Over.
4. Choose an interaction, such as Play Transition to State or Go To URL.
   - If you choose Play Action Sequence, edit the action sequence in the Timelines panel. For more information see “Edit an action sequence” on page 32.
   - If you choose Go To URL, enter the URL, and select a window for displaying the web page.
   - If you add an interaction used to control video, select a video to control. This video must exist in the project.
   - If you select Play Transition to State, choose which state to view when the event occurs.

Note: By default, new interactions apply to every instance of the component or group, unless you indicate a specific state when adding the interaction. The default setting is When In Any State. When an interaction is set to function only in a specific page or component state, you are creating a conditional interaction.

Create action sequences

Action sequences are interactions that trigger one or more actions. Action sequences occur within a single state, so they can play over and over. For example, you can have an object that animates each time a user moves the pointer over it.
The types of actions that are available include:

- Play, pause, or stop a video
- Control the playback of a SWF movie
- Set the component state
- Set the properties of an object
- Fade an object
- Add a sound effect
- Move, resize, or rotate an object
- Rotate an object in 3D

Action sequences are added to components or groups using the interactions panel.

**Note:** To add an action sequence to a component or group within another component, double-click the parent component to open it in Edit-In-Place mode.

1. Select the component or group to which you'll add the action sequence.
2. Click Add Interaction in the Interactions panel.
3. Choose a method to trigger the action sequence.
4. Choose the Play Action Sequence interaction.
5. Choose the state where the action sequence occurs (or leave the default setting When In Any State).
6. Click OK.

An empty action sequence is added to the Timelines panel and ready for editing.

## Edit an action sequence

Action sequences are edited in the Timelines panel. Editing an action is similar to editing a transition.

1. In the Timelines panel, select the action sequence you want to edit.
2. Select an object in the artboard, click Add Action, and choose an action or effect from the pop-up menu.
3. Repeat step 2 for any other objects, or add additional actions to the same object.

The Timelines panel displays the effects bar for each action you add to the sequence.

4. To shorten or lengthen the duration of the effect, drag the resize handle. To move the action to begin earlier or later, drag the effects bar rather than the resize handle.
5. To preview the action sequence, click the Play button (right-pointing arrow) in the Timelines panel.
On Application Start interactions

You can create an interaction that plays automatically when someone starts the application. This is called an On Application Start interaction. For the interaction type, you can choose to play a transition to state, go to a URL, control a video, or play an action sequence. For example, you use an On Application Start interaction to trigger an action sequence that plays a SWF file. When you add an action sequence, you can use the create an On Application Start interaction, make sure that nothing is selected in the artboard when you click Add Interaction. The actions you define occur as soon as the application starts.

To do this:

1. Import your SWF file to your Flash Catalyst project.
2. Make sure nothing is selected in the artboard.
3. In the Interactions panel, click Add Interaction.
   
   **Note:** When nothing is selected in the artboard, On Application Start appears as the default event to trigger the interaction.

4. In the Interactions panel, choose Play Action Sequence (in the second menu.)
   An empty action sequence is added to the Timelines panel.

5. Select your SWF object in the artboard. Click Add Action in the Timelines panel, and choose SWF Control > Play.
   This assigns the Play SWF action to your SWF.

Conditional interactions

Conditional interactions are behaviors predicated upon some condition. For example, clicking a Next button takes the user viewing page 1 to page 2, and the user viewing page 2 to page 3. Conditional interactions are added just like any other interaction. The only difference is that you change the conditional setting from When In Any State to something more specific.

Conditional list interactions

You can add conditional interactions to a data list that trigger an action when someone selects an item in the list. The list can be images or text. Conditional interactions are similar to other interaction. The difference is that the conditional setting, When In Any State, becomes When Any Item Is Selected or When A Specific Item Is Selected. If you choose When A Specific Item Is Selected, you enter the number of the item in the list that triggers the interaction.
Conditional list interaction
Chapter 10: Transitions and the timeline

Transitions are animations that play in an interactive project as a user moves from one page state (view) to another, or from one component state to another. Common transitions are fade ins and fade outs, rotating or moving objects, or resizing images. Flash Catalyst transition effects are created using time-based animation.

Anytime the content in one state of your project differs from the content in another state, Flash Catalyst automatically creates a default transition for you. These default transitions appear in the Timelines panel. Default transitions always have durations of zero seconds to start with, so they’re really more like placeholders— they have no effect until you increase the amount of time they play.

Default transitions, with durations of zero seconds, are created automatically on the Timeline between two states (Main and Fly) with differing content.

You can edit a transition, for example, adjusting the speed to slow it down or speed it up; by dragging the effects bars on the timeline. You can choreograph the timing of when an image in your starting state fades out in relation to when an image in your ending state fades in, by moving the effects bars.
Adjusting the Fade Out and Fade In transitions, to increase the time it takes to move between the start and end states, creating a more gradual transition.

**Note:** The type of default transition (Fade, Move, and so on) depends on how each instance of an object differs from one state to another.

The following transition effects are added for you automatically:

- Fades (fade in or fade out)
- Move
- Rotate
- Resize

Transition effects are not added when you change the following properties:

- Stroke or fill
- Opacity
- Corners
- Blend modes
- Add filters
- Edit the text in a text object (same text object with different type in each state)
- Text properties

## Edit transitions

1. In the Pages/State panel, select either the beginning or ending state of the transition.

   **Note:** To edit a component transition, double-click the component to open it in Edit-In-Place mode. The component transitions appear in the Timelines panel.
2 Select a transition in the State Transitions section of the Timelines panel.

3 Click Smooth Transition.

   The default transition changes from zero to one half second, creating a smooth transition between states.

   **Note:** You can also click the Down Arrow beside the Smooth Transition button and enter a different duration for the transition.

4 To shorten or lengthen the duration of a transition, drag the resize handle. To move the transition to begin earlier or later, drag the transition effects bar rather than the resize handle.

5 To preview the transition, click the Play button (right-pointing arrow) in the Timelines panel.

   You can also use the Properties panel to define properties for a selected transition.

   **Note:** Transition effect bars are color coded. Effect bars are green. The selected effect is blue. Yellow bars represent effects that Flash Catalyst adds automatically to preserve the fidelity of your transitions.

---

**Flash Catalyst helper effects “yellow bars”**

In some cases, changes to objects that are currently part of a transition can negatively affect the appearance of the transition. For example, yellow bars appear when you move a group (or its children) on one side of the transition. Flash Catalyst adds additional effects to adjust for the change and correct the transition automatically. The added effects appear as yellow bars and a message appears in the HUD. Example message: “This group has children with different properties in other states. Extra effects were added to your timelines to make them play correctly.”

Follow these rules to preserve the intended appearance of the transition:

- If you change the Delay value of the transition, change the Delay value for the yellow effect bar to match. The original effect bar and the yellow effect bar must stay in sync.
- Do not manually change the duration of a yellow bar effect. Flash Catalyst adjusts the yellow effect bar duration if necessary.

**Common effect properties**

- **Duration** Determines how long the effect lasts from start to finish.
- **Delay** Delays the start of the effect relative to the start of the transition or action sequence.
Repeat  Repeat the effect a specified number of times. Select Forever to repeat the effect continuously.

To and From Opacity  Set the start and end opacity of an object in a fade in/fade out effect.

X and Y Position  Set the start and end position of an object in a move effect.

Width (W) and Height (H)  Set the start and end size of an object in a resize effect.

To and From Angle  Set the start and end angle of an object in a rotation effect.

Easing  Add gradual acceleration or deceleration during an animation, which makes your animations appear more realistic.

Easing transitions
You can achieve more realistic looking movements by applying easing to your effects. Easing consists of two phases: the acceleration, or ease in phase, followed by the deceleration, or ease out phase.

Easing is added in the Properties panel and there are several easing options:

Default  Applies a constant rate of change from start to finish.

Linear  Starts out slow, quickly easing into the effect. It then maintains a constant rate until just before the end of the effect when the rate slows down, easing out of the effect.

Sine  Eases in and accelerates to a mid point. It then immediately begins decelerating, or easing out.

Power  Power is similar to Sine because it eases in to a point and then begins easing out. But with the Power option, you can also set the Exponent property. A higher exponent value creates greater acceleration and deceleration.

Elastic  Causes a moving object to snap back and jiggle one it reaches its destination.

Bounce  Causes the moving object to reach its destination, and then bounce backward before settling into its final position.

Add extra effects to a transition
You can add more than one effect to the same objects to create more advance transitions. For example, an object can fade in, rotate in 3D, and play a sound effect at the same time.

1  Open the Timelines panel.

2  Select a transition in the State Transitions section of the Timelines panel.

3  Select an object in the Timeline.

4  Click Add Action, and choose an action or effect from the pop-up menu.

5  Adjust the effect properties in the Timeline or Properties panel.

The following is a list of the effects and actions in the Add Action pop-up menu:

Video Control  Play, pause, or stop a video. Import your video and add a video player before you can control video playback. For more information, see “Video and sound” on page 60.

SWF Control  Play or stop a SWF movie. You can also add play or stop a SWF movie at a specific frame in the SWF movie. Set the Start Frame value in the Properties panel.

Set Component State  Display a specified state of a component. Specify which state to display in the Properties panel.

Set Property  Change a property of a component or group as the result of a user interaction. Specify which property to change in the Properties panel.

Fade  Fade an object from one opacity setting to another (fade in or fade out). Set the From and To Opacity values in the Properties panel.
**Sound Effect**  Play any sound effect in the project library. In the Properties panel, set the sound to play once or repeat. If you choose Repeat, you can then set the Count value (number of repeats). You can choose Forever to make the sound play continuously in a loop.

**Move**  Move an object from one location to another. In the Properties panel, choose Relative to move the object a specific number of pixels from its starting position. You can also choose Specific Location to move the object to an exact X and Y location. When used in a transition, the effect is based on position in the old and new states.

**Resize**  Resize an object. In the Properties panel, choose Relative to change the height and width to a specified percentage of its current size. You can also choose Specific Size to change the height and width to an exact number of pixels. When used in a transition, the effect is based on size in the old and new states.

**Rotate**  Rotate an object. In the Properties panel, choose Relative to rotate the object relative to its current angle (if the object begins rotated). Choose Specific Angle to rotate the object to a specific angle (starting from 0°). When used in a transition, the effect is based on angle in the old and new states.

**Rotate 3D**  Rotate an object in three dimensions. Using the Properties panel, you can set From and To angles for rotation around the object’s center, a vertical axis, and a horizontal axis.

---

**Smooth transition options**

Clicking Smooth Transitions in the Timelines panel adds the default Smooth Transition settings to the effects in the Timeline. You can change the default settings in the Smooth Transition Options dialog box.

![Smooth Transition Options dialog box](image)

- **Duration**  Sets the overall time of the transition from start to end. The start of the transition is at 0 seconds in the Timeline, not when the first effect begins playing.

- **Simultaneous**  Applies smooth transitions to each effect equally, using the value you set in the Duration field. Each effect begins and ends at the same time.

- **Smart Smoothing**  Adjusts the duration and delay (start time) of each effect, creating a series of staggered effects. The effects play at different times over a duration you specify. Flash Catalyst uses a logical order for effects, beginning with objects fading out. After objects fade out, all resize and move effects play, followed by objects fading in.

- **Overwrite Existing Effects**  Replaces existing transition settings with the settings in the dialog box.
Chapter 11: Creating scrolling images, panels, and lists

When your projects require fitting large amounts of content in a limited space, creating scrolling images, panels and lists can be a great solution. Flash Catalyst includes two interactive components specially designed for this purpose: data lists and scroll panels.

A data list is a special type of component used to retrieve and display a series of related items; though the name data list is a little misleading. Each unique record in a Flash Catalyst data list can include artwork, text, or a combination of both. It doesn’t need to be a list at all.

Traditionally, a data list might look something like a spreadsheet or data table.

![Data List Example](image)

Using Flash Catalyst, you can build a Data List component that displays a tiled wall of images.

![Tiled Wall of Images](image)

A list can be a scrolling filmstrip or series of thumbnails, from which you select and view other content or navigate to new locations in the application. By adding a scroll bar, you can extend the list to include any number of items.

![Scrolling Filmstrip](image)
You can create a horizontal data list; adding scroll arrows allows movement forward and backward through the list.

Overview of data lists

- You can arrange a data list horizontally, vertically, or in a grid on the page.
- By adding a scroll bar, you can extend the list to include any number of items.
- Every data list component must include a master item called the “repeated item.” The repeated item is a template that defines the appearance of every item in the list. For example, you can create a repeated item with an image, descriptive text, and different up, over, and down states. Each item in the list shares these common elements and properties. Changes applied to the repeated item are applied to every item in the list automatically at runtime.
- Most data lists are connected to a data source and populated with data dynamically at runtime. A developer can make this connection using Adobe Flash Builder. In Flash Catalyst, you can specify placeholder data to display in the list using the Design-Time Data panel.

Create a data list component

1 Position a copy of the first data list items on the artboard. If the list requires a slider, scroll bar, or similar control, add it to the artboard. Size the control according to your design plan. Select these objects.

2 In the HUD, click Choose Component > Data List.

Flash Catalyst creates the data list and issues a message in the HUD. The message asks you to specify which graphic elements to use for the required part of the data list. The required part is a repeated item.

3 With the new component still selected on the artboard, click Edit Parts in the HUD.

Flash Catalyst enters Edit-In-Place mode to allow you to edit the parts and states of the component.

4 On the artboard, select the items to use as the repeated item. Do not include the scroll bar or other controls in the repeated item.

5 In the HUD, click Choose Part > Repeated Item (Required).
Flash Catalyst converts the selected item into the repeated item part. By default the list is aligned vertically.

6 Select the repeated item and choose Vertical, Horizontal, or Tile in the Layout section of the Properties panel. Use the Properties panel to apply additional formatting, such as cell padding. Use the selection handles to size the repeated item bounding box according to your design plan.

7 Double-click the repeated item to open it in the Pages/States panel.

A repeated item has normal, over, and selected states.

8 Edit the items in each state according to your design plan.

9 Close the data list component and return to the artboard.

You have created a data list component, but at first it displays the same repeated item over and over. You can use the Design-Time Data panel to replace the temporary images with more realistic data. The design-time data shows a developer how the application looks at runtime.

### Add design-time data

1 Select the data list component on the artboard and open the Design-Time Data panel.

The Design-Time Data panel shows the items in your list. At first, every item in the list is the same.

2 If the repeated item includes text, you can edit the text for each item in the list. If the repeated item includes an image, click one of the temporary images in the Design-Time Data panel.

   The Select Asset dialog box opens.

3 In the Select Asset dialog box, select an image to display in the data list and click OK.

   The Design-Time Data panel updates to show the new images and text.

   **Note:** If the project library does not include the image you want to display in the data list, you can import it.

4 Replace the other repeated items with design-time data.

5 To add additional items to the data list, click Add Row and replace the temporary image with an image of your choice.
A. Design-Time Data panel (shown expanded) B. Select Asset dialog box

Note: After creating the data list, you can add additional images or text to the repeated item. Open the repeated item and add the first instance of the new image or text. Select the new item and choose Modify > Add Text To Design-Time Data or Add Image To Design-Time Data. A new column is added to the Design-Time Data panel. To remove an item from the repeated item, select it and choose Modify > Remove From Design-Time Data.

You can view an excellent example of creating a data list here: Flash Catalyst Beta 1: Building a Website II.

Overview of a scroll panel

A common challenge in web design is finding space in the available window to display all of the necessary content. One solution is to create scrolling panels. A panel creates a well-defined container for content in the user interface. By adding scrolling content and a scroll bar, you can place a large amount of information in a limited space. To create a scrolling panel in Flash Catalyst, you need:

- An object to define the panel area, such as a rectangle shape (optional)
- Scrolling content, such as a long block of text or a series of images (required)
- A scroll bar used to scroll the content (recommended)

Note: You can create a scroll panel without a scroll bar, but it’s useless unless users can scroll to see the hidden content.

Create a scroll panel component

1 Import or draw an object to define the panel area (optional).
2 Add the content that you want to scroll. To create scrolling text, use the Text tool in the Tools panel.
3 Position the scrolling text or align a series of objects in the panel area. Leave some room along the right or bottom edge of the panel for a scroll bar.

Note: Your scrolling content extends beyond the panel area temporarily.
4 Create a scroll bar component or drag a scroll bar from the Wireframe Components panel. Position and size the scroll bar to match the size of the panel area.

![Two examples of scroll panel parts, before creating the scroll panel component](image)

5 Select all of the parts for the scroll panel. In the HUD, click Choose Component > Scroll Panel. A message in the HUD reminds you to edit the parts of the component.

6 Click Edit Parts. Another message tells you how to create the scrolling part of the panel.

7 Select the objects you want to scroll (text block or series of objects).

8 In the HUD, click Choose Part > Scrolling Content. A new bounding box defines the visible area of the scrolling content.

9 If necessary, size the bounding box of the scrolling content to fit within the panel area.

10 Use the Breadcrumb bar to close the scroll panel. Choose File > Run Project to test the component.

![Completed scroll panel component used to scroll a block of text in a confined panel area](image)

For more information on creating text in Flash Catalyst, see “Creating shapes, lines, and text” on page 45.
Chapter 12: Creating shapes, lines, and text

Flash Catalyst CS5 includes a set of tools for creating and modifying basic shapes and text. These tools are typically used for rapidly creating an application prototype. Other uses include customizing the built-in wireframe components or quickly adding elements that don’t require the advanced features of a Creative Suite application. The drawing and text tools are located in the Flash Catalyst Drawing toolbar.

Note: After creating artwork with the drawing tools, you can edit those drawings in Adobe Illustrator or Adobe Photoshop using Flash Catalyst round-trip editing. See “Round-trip editing” on page 57.

Draw shapes and lines

- Click a drawing tool in the Tools panel to select it. Some tools share a spot in the menu. To select a hidden tool, click and hold down the mouse button to open the pop-up menu, and then select a tool.
- Drag in the artboard to draw a shape.
- Hold down Shift as you draw with the Rectangle or Rounded Rectangle tools to create a perfect square.
- To create a rectangle with rounded corners, use the Rounded Rectangle tool. You can also use the Rectangle tool and change the Corners value in the Properties panel.
- Hold down Shift as you draw with the Ellipse tool to draw a perfect circle.
- Drag the mouse as you draw triangles, hexagons, octagons, and stars to rotate the shapes as you draw them.
- Use the Line tool to draw lines. Hold down Shift to draw lines at perfect vertical, horizontal, or 45 degree angles.
Also see “Modify drawing and text properties” on page 47.

Add text

Use the Text tool to create three types of text.

**Point Text** Does not line wrap. The text extends to fit all of the text. To add a line, you can press Enter (Windows) or Return (Mac) to insert a line break.

**Area Text** Occupies a bounding box with fixed width and height. The text never grows any larger than the width and height you specify. Text automatically line wraps, but you can also enter manual line breaks. If the text does not fit within the box, the remainder is hidden. An overflow icon appears at the bottom of the bounding box. Clicking the overflow icon changes the text to Fit Height. The bounding box height adjusts automatically.
**Fit Height**  Text occupies a box with fixed width but variable height. The text stays within the width of the bounding box. Text automatically wraps. You can also insert manual line breaks. The height of the box grows automatically, if needed, to fit all of the text.

- Select the Text tool and click or drag in the artboard.
- Clicking the Text tool in the artboard places the insertion point and creates Point Text.
- Dragging the Text tool in the artboard creates area text. There are two ways to resize the text bounding box. Double-clicking inside the box reveals four selection handles. Drag the handles to resize the box. Or, use the Select or Direct Select tools to select the text bounding box. Selecting the box reveals eight selection handles. Drag the handles to resize the bounding box.
- To change a text object from one type to another, use the Select or Direct Select tool to select the bounding box. In the Properties panel, choose Point Text, Area Text, or Fit Height.
- Resizing Fit Height text converts it to Area Text.

*Note:* You can also copy text from external sources and then paste it in the artboard. Copied text does not retain its original formatting.

For information on formatting text appearance, see “Modify drawing and text properties” on page 47.

**Select and position objects**

- Use the Select tool (dark arrow) to select and move grouped or ungrouped objects.
- Use the Direct Select tool (light arrow) to select objects that are inside a group.
- Drag a selected object to move it in the artboard. When moving an object, hold down Shift to move along a perfect horizontal or vertical path.
- Select an object and change its position values (x/y) in the Properties panel to position the object in an exact location.
- When positioning objects in the main application artboard, the x and y values are relative to the upper-left corner of the artboard. The upper-left corner represents X:0 and Y:0.
- When positioning parts within a component in Edit-In-Place mode, the x and y values are relative to the component bounds.
- After grouping objects, the x and y positions of its children are relative to the upper-left corner of the group.

  *You can nudge objects 1 pixel up, down, left, or right using the arrow keys. Hold down Shift as you press the arrow keys to nudge the object 10 pixels.*

**Size and rotate objects**

- When you select an object, eight selection handles appear. Drag the handles to size the object vertically, horizontally or diagonally.

*Note:* You cannot add, remove, or edit points on a path in Flash Catalyst. You can launch and edit the artwork in Adobe Illustrator. For more information, see “Round-trip editing” on page 57.
• When resizing an object, hold down Shift as you drag a selection handle to maintain the current height to width ratio. Hold down Alt (Windows) or Option (Mac) to resize from the center of the object instead of from the opposite edge or corner.

• Use the Transform tool to rotate and size selected objects. First select the object and then select the Transform tool. To size the object, drag a selection handle. To rotate an object, position the pointer over the object and drag. Hold down Shift as you rotate to constrain the rotation to 45 degree angles.

• With the Transform tool selected, hold down Ctrl (Windows) or Command (Mac) to toggle between the Transform and Select tools.

💡 **To size a component you can either:**

• Size its parts individually using Edit-In-Place mode. See “Edit-In-Place” on page 27.

• Size its parts all at once using Edit in Adobe Illustrator CS5. See “Launch and edit in Adobe Illustrator CS5” on page 57.

---

**Share drawn objects to other states**

When you draw a graphic object in Flash Catalyst, the object is added to the current state only. Once you finish creating the object, you can add it to the other states of the application or component. Sharing an object to other states makes that object present and visible in the states you specify. After sharing an object to other states, the object can have different properties in each state.

1. Select the object.
2. Choose States > Share to State > All States (or choose a specific state).

---

**Modify drawing and text properties**

You can change the properties of shapes, lines, and text in the Properties panel.

• The properties change, depending on what you have selected. Some properties are unique to the selection. Others, such as Filters, are common to most objects in Flash Catalyst.

• When you select a group, the panel displays the properties of the group as a whole, not its children.

• When you move over a numeric value in the Properties panel, the cursor changes to a fingertip with a double-head arrow, called a scrubber. Drag horizontally to increase or decrease the value or click and type a new value. You can also double-click the control and type a new value.

• Click the triangle next to a property to see extended options, such as fill opacity or gradient rotation.

The Opacity and Rotation properties are common to shapes, lines, text, and most other Flash Catalyst objects.

**Opacity**  Set the opacity of an object from 0% to 100%. An object with 0% opacity is transparent.

**Rotation**  Rotate an object. The value is equal to the rotation angle (0 – 360°) from its original position. If a shape, such as a star, was originally drawn at an angle, its starting position is still 0. Use negative values to rotate the object counterclockwise.

For information on copying properties to the same object in other states, see “Make objects the same in all states” on page 51.
Shape and line properties

Shapes and lines share most of the same properties.

**Shape and line properties**

*Rotate By*  Rotate a line a specific angle from its current position. Each time you rotate the line, its new position becomes the starting (0) position.

*Corners*  Make the corners of a rectangle round. You can change the corners of a rectangle or rounded rectangle.

**Stroke and fill**

The interior of a shape is its Fill. The border or outline around its outer edge is the Stroke. You can apply one of three types of stroke and fill: none, solid, or linear gradient.

- Select the Solid, Gradient, or None option.
- If you select Solid, click the color box to open the Color Picker and select a new color.
- If you select multiple objects with different stroke or fill, the properties show no stroke or fill. Any new properties you choose are added to all selected objects.

The following are properties within the stroke and fill properties:

*Weight*  Change the weight (thickness) of a stroke line.

*Opacity*  Stroke and Fill both have opacity values separate from the object’s opacity value.

*End Cap: None*  A cap is the end of an open line. The None option is flush with the path’s end.

*End Cap: Round*  Adds semicircular ends that extend half the line width beyond the end of the line.

*End Cap: Square*  Adds a square cap that extends beyond the path by half the stroke width.
Joints  A joint is where a line changes direction (turns a corner).

Miter Limit  Adjust the amount of miter applied to a miter joint.

Use the Color Picker
When you select the color box for stroke or fill, the Color Picker opens. You can select a color or enter a hexadecimal color value. For additional colors, drag the slider (right-pointing arrow) up or down. Select a new color range and drag in the color field to select a new color. You can also sample a color in the application by using the Eyedropper tool.

Choosing the eyedropper icon in the Color Picker activates the Eyedropper tool in the artboard. While the tool is active, you can do the following:

- Click in the artboard to set the swatch color to the color under the eyedropper. After you sample the artboard color, the Color Picker disappears and you return to the previous tool mode.
- Click the eyedropper icon again to leave the Color Picker open and return to the previous tool mode.
- If you select multiple objects of different colors, the properties show that no color is applied. Selecting a color in the color swatch applies the new color to all of the selected objects.

Gradients
After you apply a gradient stroke or fill, a gradient swatch displays a preview of the gradient from left to right. A checkerboard pattern indicates areas of transparency. Beneath the swatch are interactive handles for gradient color stops.

- Click anywhere in the gradient swatch to add a new stop.
- Click a stop without dragging to set the stop’s color and opacity.
- Drag a stop to move it.
- Drag a stop away from the swatch to remove it.
  
  Note: You cannot remove stops when there are only two stops left. You can remove the first or last stops as long as other stops exist in the middle.

- If you select multiple objects with different gradients (or some with no gradients), the properties show that no gradient is applied. Clicking the blank gradient swatch resets all items to the default gradient.
- You can change the stroke or fill of from solid to gradient. The result is a gradient with the original solid color changing to black. If you change it from a gradient to a solid, the start color from the gradient is used as the new solid color. If you change the color setting from none to gradient, the result is a black to white gradient.
- You can change the Rotation property to rotate the angle of gradient.
Middle-click the Rotation dial control within the Gradient Fill properties to reverse the angle or direction of the gradient 180°.

For information on copying properties to the same object in other states, see “Make objects the same in all states” on page 51.

Text properties

You can format text by using the Properties panel.

- To format text, select its text bounding box and specify properties in the Properties panel.
- To format a portion of text within the bounding box, double-click inside the text bounding box, and then highlight the text you want to format. The properties you set apply only to the highlighted text.
- To change text color, select the text and click the color box in the Properties panel to open the Color Picker. Select a new color or use the Eyedropper tool to sample a color in the artboard.

The following additional properties are unique to text:

Font  Change the font and style, such as bold or italic.
Size  Select a size for the text from 1 through 720 points.
Underline  Apply an underline to the text.
Strikethrough  Format the text to appear as if a line has been drawn through it.
Alignment  Align the text within its bounding box. Choose Left, Right, Center, or Justify.
Baseline Shift  Set the position of the text relative to its baseline. Choose between None, Superscript, or Subscript.

Kerning  Kerning puts a predetermined amount of space between certain character pairs to improve readability.

Line Height  Adjust the space between each line of text. You can set a specific size in pixels or choose a percent of its current font size.

Tracking  Tracking differs from kerning in that tracking is the adjustment of space for groups of letters and entire blocks of text. Use tracking to change the overall appearance and readability of the text, making it more open and airy or more dense.

Padding  Create space between the text and the surrounding edges of its bounding box.

Make objects the same in all states

If you edit the properties of an object that exists in multiple states, you can apply the same changes to all states.

1  Select the object.

2  In the HUD, choose Make Same In All Other States.

Filters

Filters are not specific to shapes, lines, and text. You can apply the same filters to bitmap images, components, and video players. You can also apply filters to groups and the filter is applied to all children in the group equally.

Add filters

You can apply the following filters in the Properties panel: Blur, Drop Shadow, Inner Shadow, Bevel, Glow, Inner Glow.

- Click to open the Add Filter button (plus sign), and choose a filter.
- After you apply a filter, additional filter settings appear in the Properties panel.
- You can apply multiple filters to the same object. The order in which you apply filters in Flash Catalyst affects the final appearance of the combined filters.
- To remove a filter, click the remove filter button (x in a circle).

Note: You cannot animate changes to filters.

![Drop Shadow filter properties](image-url)
Filter properties
Color Select a color for the filter. Click the color box to open the Color Picker and select a color or use the Eyedropper to sample a color in the artboard.

Distance Set the distance a drop shadow or glow extends beyond the edge of the object. Set how far a blur extends into the object from its edges. Set the size of a beveled edge.

Angle Change the angle that a drop shadow or bevel extends in relation to the object.

Use a different distance and angle in a drop shadow filter to alter the perceived direction of lighting.

Blur Add blur to give a filter a softer effect.

Opacity Change the opacity of a filter to give it a more realistic appearance.

Strength A stronger setting makes a filter more apparent, but can make it appear less realistic.

Knockout Knockout hides the original object, but shows only the parts of the filter that would be seen if the object were visible.

Hide Object Hide Object hides the original object, and shows the filter including parts that would have been obscured if the object were visible. Hide Object has no effect if Knockout is also selected.

Note: There is a known bug that causes filter effects to size incorrectly relative to their object when changing the zoom magnification. Rasterizing the object can cause the filter to shift position. The effects display correctly at 100% magnification. The effects also display correctly when you publish the application.

Blending modes

Blend Modes are used to determine how layered objects blend together. It’s helpful to think in terms of the following colors when visualizing a blend mode effect:

- The base color is the original color in the image.
- The blend color is the color being applied in a layer above it.
- The result color is the color resulting from the blend.

Topmost object with Normal blending (left) compared to Hard Light blending mode (right)
A. Base colors in underlying objects at 100% opacity  B. Blend color in topmost object  C. Resulting colors after applying the Hard Light blending mode to the topmost object
Blending mode descriptions

Choose blend modes in the Appearance section of the Properties panel.

**Normal**  Paints the selection with the blend color, without interaction with the base color. This is the default mode.

**Darken**  Selects the base or blend color—whichever is darker—as the resulting color. Areas lighter than the blend color are replaced. Areas darker than the blend color do not change.

**Multiply**  Multiplies the base color by the blend color. The resulting color is always a darker color. Multiplying any color with black produces black. Multiplying any color with white leaves the color unchanged. The effect is similar to drawing on the page with multiple magic markers.

**Color Burn**  Darkens the base color to reflect the blend color. Blending with white produces no change.

**Subtract**  Looks at the color information in each layer and subtracts the blend color from the base color. In 8- and 16-bit images, any resulting negative values are clipped to zero.

**Lighten**  Looks at the color information in each channel and selects the base or blend color (whichever is lighter) as the result color. Pixels darker than the blend color are replaced, and pixels lighter than the blend color do not change.

**Screen**  Multiplies the inverse of the blend and base colors. The resulting color is always a lighter color. Screening with black leaves the color unchanged. Screening with white produces white. The effect is similar to projecting multiple slide images on top of each other.

**Color Dodge**  Brightens the base color to reflect the blend color. Blending with black produces no change.

**Add**  Looks at the color information in each layer and brightens the base color to reflect the blend color by increasing the brightness. Blending with black produces no change.

**Overlay**  Multiplies or screens the colors, depending on the base color. Patterns or colors overlay the existing artwork, preserving the highlights and shadows of the base color while mixing in the blend color to reflect the lightness or darkness of the original color.

**Soft Light**  Darkens or lightens the colors, depending on the blend color. The effect is similar to shining a diffused spotlight on the artwork. If the blend color (light source) is lighter than 50% gray, the artwork is lightened, as if it were dodged. If the blend color is darker than 50% gray, the artwork is darkened, as if it were burned in. Painting with pure black or white produces a distinctly darker or lighter area but does not result in pure black or white.

**Hard Light**  Multiplies or screens the colors, depending on the blend color. The effect is similar to shining a harsh spotlight on the artwork. If the blend color (light source) is lighter than 50% gray, the artwork is lightened, as if it were screened. This is useful for adding highlights to artwork. If the blend color is darker than 50% gray, the artwork is darkened, as if it were multiplied. This is useful for adding shadows to artwork. Painting with pure black or white results in pure black or white.

**Difference**  Subtracts either the blend color from the base color or the base color from the blend color, depending on which has the greater brightness value. Blending with white inverts the base-color values. Blending with black produces no change.

**Exclusion**  Creates an effect similar to but lower in contrast than the Difference mode. Blending with white inverts the base-color components. Blending with black produces no change.

**Invert**  Inverts the base and blend colors.

**Hue**  Creates a resulting color with the luminance and saturation of the base color and the hue of the blend color.

**Saturation**  Creates a resulting color with the luminance and hue of the base color and the saturation of the blend color. Painting with this mode in an area with no saturation (gray) causes no change.

**Color**  Creates a resulting color with the luminance of the base color and the hue and saturation of the blend color. This preserves the gray levels in the artwork and is useful for coloring monochrome artwork and for tinting color artwork.
Luminosity  Creates a resulting color with the hue and saturation of the base color and the luminance of the blend color. This mode creates an inverse effect from that of the Color mode.

Lighter Color  Compares the total of all values for the blend and base color and displays the higher value color. Lighter Color does not produce a third color, which can result from the Lighten blend. It chooses the highest values from the base and blend colors to create the result color.

Darker Color  Compares the total of all values for the blend and base color and displays the lower value color. Darker Color does not produce a third color, which can result from the Darken blend. It chooses the lowest values from both the base and the blend color to create the result color.

Copy Alpha (when isolated)  Applies an alpha mask.

Erase Alpha (when isolated)  Removes all base color pixels, including colors in the background image.

Note: Copy Alpha and Erase Alpha blend modes only work when you place them inside a component and leave the component’s blend mode set to Isolated.
Chapter 13: Optimizing graphics

Flash Catalyst supports both vector and bitmap graphics. The objects you create with the Flash Catalyst drawing tools are vector graphics. Vector graphics are ideal for illustrations, small type, or bold images created with lines and shapes that must look crisp, even when scaled. Bitmaps are better suited for photography.

Optimize large bitmap image or vector drawing with hundreds of paths. Optimizing images makes them easier to work with in Flash Catalyst and your finish application runs more efficiently. For example, complex sets of vector graphics (like freeform artwork or corporate logos) that do not need to change between states can be optimized.

**Vector graphics** Are mathematical equations describing the distance and angle between two points. Additional information, such as the color and thickness of the line (stroke) and the content of the path (fill) can also be set. Vectors can be sized up or down with no detrimental impact to the vector shape.

**Bitmap (Raster) images** Are made of a specific number of pixels mapped to a grid. Each pixel has a specific location and color value. An image with more pixels has a higher resolution and a larger file size.

In Flash Catalyst, graphic optimization options include converting vector graphics to bitmaps, compressing images, and converting embedded images to linked files. When you select a graphic object, optimization options appear in the Heads Up Display.

**Optimize Vector Graphics** Compile the selected graphics into a low-level Flash object. They display more quickly in Flash Catalyst and at runtime. Once you optimize a vector drawing in Flash Catalyst, you can no longer edit its stroke and fill. In an optimized vector graphic file, all MXML information (vector, stroke, path, fill, and so on) is kept separately in an FXG file. When you optimize a vector graphic, a new optimized graphic is added to the Library panel in the Optimized Graphics category.

**Rasterize** Converts a static vector graphic or text into a bitmap image. Use the Rasterize option to optimize static vector graphics or text.

*Note: Rasterizing a graphic object that has a blend mode, can cause it to display incorrectly.*

**Compress** Lets you add compression to a bitmap image. Compressing an image reduces the file size of an image, but also reduces the image quality. When you compress an image with transparency, the transparency is lost. When you compress a bitmap image, a compressed copy is added to the Library panel. The original uncompressed image remains in the Library panel.

**Convert to Linked Image** By default the images you add to your application are embedded and published as part of the SWF file. To reduce the size of your application, you can link images. Linking an image stores it outside the application (SWF file) and loads the image when you run the application. If you link assets, then copy the linked files to the web server where you deploy your application (SWF file).
Deciding when to optimize images
There are trade-offs of optimizing images. Using the Optimize Vector Graphics options makes it so that you can later break the graphic apart and re-edit the content. It produces a smaller SWF file size than a bitmap.

When you Rasterize a graphic (convert to a bitmap) you can see better performance in Flash Catalyst, but at the cost of a larger SWF file. Scaling a bitmap can cause it to look incorrect.

Optimize with good design
One of the best ways that you can optimize your application is to make the best use of assets, pages, states, and components. The following are some things to consider when building an optimized application.

- Optimize graphics
- Use a single instance of an asset and share it to states. For more information, see “Share objects between pages and states” on page 18.
- When adding multiple videos to a project, use one instance of a video player. You can edit its properties in different states to display and control a different source video. For more information, see “Add video” on page 60.
- Limit the number of main application pages in your application. To create more views or screens, use the different states of a custom component. Use nested components to create sites with more depth of content and fewer pages. For more information, see “Interactive components” on page 24.

Optimize before import
There are several ways to optimize the performance of your application before bringing artwork into the project.

- Make sure that bitmap/raster images are 72 dpi.
- Make sure that the color mode is RGB.
- Use Align To Pixel Grid in Illustrator.

💡 When designing artwork for Flash Catalyst using Adobe Illustrator, you can use the Flash Catalyst document profile to automatically apply optimum settings. The profile applies settings for document size, color mode, PPI, and Align To Pixel Grid. In Illustrator, click Flash Catalyst Document in the Create New section of the Welcome screen. You can also choose File> New to open the New Document window. Click to open the New Document Profile menu and select Flash Catalyst.

- When creating videos, use a preset or codec and compression settings that are optimized for the web.
Chapter 14: Round-trip editing

Using Flash Catalyst round-trip editing, you can launch and edit your application artwork using the rich editing capabilities of Adobe Illustrator CS5 and Adobe Photoshop CS5. Open the artwork in Illustrator or Photoshop, make your edits, and then return to Flash Catalyst.

Note: FXG is the rich graphics interchange format used for round-trip editing. For more information on FXG files, see Working with FXG.

- Use Illustrator to round-trip edit bitmaps and vectors. Use Illustrator to edit a single object, a mixed selection of objects, or a group. Using Illustrator, you can also edit the following components: Button, Checkbox, Radio Button, Horizontal Scrollbar, Vertical Scrollbar, Text Input, Toggle Button, Horizontal Slider or Vertical Slider. You cannot round-trip edit Custom/Generic components.

  Note: You cannot round-trip edit more than one component at a time. You cannot round-trip edit graphics that have been optimized by choosing Optimize Vector Graphic.

- Use Photoshop to edit bitmap images, a selection of multiple images, or a group containing only images.

  Note: If a component is part of a mixed selection or group, the custom component appears as a non-editable placeholder layer in Photoshop or Illustrator.

- When you edit a vector (shape or text), changes apply only to the state in which you select the vector.

- Make all structural changes to objects in Flash Catalyst. Changing the structure of objects during round-trip editing can break the intended behavior of objects or transitions in which they occur.

- When you edit an image or component that is stored in the Flash Catalyst library, you are editing the object definition. If you’ve shared the object to multiple states, the changes apply in all states. If the image is used inside a component, the changes are reflected in the component.

  You can simulate editing a bitmap in a single state. Add a new layer in Photoshop with a copy of the original image. Make edits to the copied layer and turn off the eyeball for the original layer.

- When you round-trip edit a button (or other component), its states are shown as separate layers in Illustrator and Photoshop. If you round-trip edit a group, its children are shown as separate layers.

- When you round-trip edit an object, the surrounding objects in the artboard are visible (but dimmed) for reference. These objects appear as locked background layers in Illustrator and Photoshop and cannot be edited.

Launch and edit in Adobe Illustrator CS5

1 Select the object you want to edit in the artboard.

2 Choose Modify > Edit in Adobe Illustrator CS5.

   The object opens in Illustrator. Other objects in the artboard appear dimmed for visual reference during editing. The non-editable artwork is added to the background layer in Illustrator and is locked.

   A message tells you that you are editing an object from Adobe Flash Catalyst.

3 If the Edit In Adobe Illustrator message appears, click OK.
4 Make your changes.

*To view blend modes correctly in Illustrator, create a filled rectangle behind the blends.*

5 When you have finished editing, click Done at the top of the application window.

The FXG Options dialog box appears.

6 Click OK to close the FXG Options dialog box and return to Flash Catalyst.

7 Return to Flash Catalyst.

The changes you made in Illustrator appear in Flash Catalyst.

For more information on editing in Illustrator CS5, see *Illustrator and Flash Catalyst workflow*.

**Launch and edit in Adobe Photoshop CS5**

To round-trip edit in Photoshop, download and install the Flash Catalyst FXG extensions for Photoshop. The extensions include the FXG plug-in and the Simplify Layers For FXG script.

*Note:* You must have the Flash Catalyst FXG extensions for Photoshop installed before you can launch and edit Flash Catalyst project artwork using Photoshop.

Instructions for downloading and installing the extensions are located here: [www.adobe.com/go/photoshopfxg](http://www.adobe.com/go/photoshopfxg)

1 Select the bitmap image you want to edit in Photoshop.

2 Choose Modify > Edit In Photoshop CS5.

A message reminds you to download and install the FXG extensions for Photoshop.

3 If you have already installed the extensions, click OK to dismiss the message.

Adobe Photoshop CS5 starts and the bitmap image you selected appears in the Photoshop canvas.

A message in Photoshop reminds you to run the FXG scripts before returning to Flash Catalyst.
4 Make your changes in Photoshop.

   When you’re done editing in Photoshop, save it as a PSD file before running the Simplify Layers For FXG script. The PSD file is your master file, preserving any layer styles (effects), adjustment layers, layer masks, smart objects that you added.

5 Choose File > Scripts > Simplify Layers For FXG.

6 Choose File > Close and click Yes to save changes.

7 Return to Flash Catalyst.

   The changes you made in Photoshop appear in Flash Catalyst.

For more information on editing in Photoshop, see Using Adobe Photoshop CS5.

**Tips for preserving fidelity during round-trip editing**

When you round-trip edit between Flash Catalyst and Illustrator or Photoshop, you are using the FXG file format to move objects between applications.

Follow these tips to preserve the fidelity of your Flash Catalyst artwork and the edits you make during round-trip editing.

- The filters you add in Flash Catalyst are editable in Illustrator.
- If you rotate, or apply a filter to a bitmap in Flash Catalyst, you cannot edit it in Photoshop until you rasterize the image. Choose Modify > Rasterize.
- Filters and effects you add in Illustrator convert to vectors or bitmaps when returning to Flash Catalyst.
- Adding layer effects, masks, shape layers, and adjustment layers in Photoshop requires that you run the Simplify Layers for FXG script before returning to Flash Catalyst. There is no harm in running the script. A good practice is to always run the script before returning to Flash Catalyst.
- Always set Proof Colors to Monitor RGB in Illustrator to lessen the difference when comparing colors between Flash Catalyst and Illustrator. Use the following steps to change the setting for Proof Colors in Illustrator:
  1. Choose View > Proof Colors (to select it)
  2. Choose View > Proof Setup > Monitor RGB

For a video with more information on setting proof colors in Illustrator, go to the 27 min mark in this video: Structuring UI design comps for use in Flash Catalyst

See the following for more information:

“Importing artwork” on page 6

Working with FXG
Chapter 15: Video and sound

Flash Catalyst CS5 supports the import of FLV files and F4V video files and of mp3 sound files. The files are added to the Media section in the Library panel. The Library panel shows the size of each video or sound file to the right of the filename.

Add video

1 To import a video file, select File > Import > Video/Sound File. Browse to locate a video file, select it, and click Open.

   The video appears in the Library panel. To preview a video, select it in the Library panel and click the Play button at the top of the panel.

2 To add a video to your design, drag it from the Library panel to the artboard. Flash Catalyst automatically wraps the video in a video player control.

3 Set properties for the video player in the Properties panel. To remove the video playback controls, change the video controls option in the Properties panel to None.

![Video player properties]

💡 You can import an FLV file or F4V file with sound only and no video. A sound-only video file can be controlled like other videos. Use this method to control the playback of large sound files, such as narration or soundtracks.

Set video player properties

To set the properties of a video player, select the video player in the artboard (or in the Layers panel). Set properties in the Properties panel. The same video player can have different properties in each state.

Opacity Change the opacity of the video in the video player.

Volume Set the volume of the audio track in the video file.

Video Controls Change the controls that appear below the video player. You can choose between Wireframe, Standard, and None.
Source: Link to a source video in the project library. You can play different video files using the same video player by changing the Source property of a video player in different states. Using one video player is one way to optimize an application.

Scale Mode: None  Video does not scale and displays at its natural size. Video is cropped if video player bounding box is smaller than the source video.

Scale Mode: Letterbox  Scale uniformly as large as possible without cropping the video. Black or white bars appear around the video if the video is a different aspect ratio than the video player bounding box.

Scale Mode: Zoom  Scale uniformly until video completely fills the frame. Video can be cropped.

Scale Mode: Stretch  Scale non-uniformly to make video fit in the video player bounding box. Video is not cropped, but can appear distorted from non-uniform scaling.

AutoPlay  The video starts playing automatically.

Loop  the video plays to the end and then repeats.

Muted  Volume is set to 0.

Accessible Text  Text that adaptive technologies recognize, such as screen readers.

You can use an action sequence to set a property for a video. For example, you can link different buttons to the same video player. Clicking button 1 plays video 1, clicking button 2 plays video 2, and so on. Add an interaction that changes the opacity of the video when the video is enabled or disabled. Add an interaction that mutes the audio or sets the video to a specific volume.

See the following for more information:
“Create action sequences” on page 31
“Edit an action sequence” on page 32

Control video playback

When you add a video player to the application, its Video Controls property is set to Wireframe. The Wireframe controls include a generic-looking set of video playback controls. These controls include a Play/Pause button, progress/scrubber bar, current time indicator, and Full Screen button.

• To change the video controls, use the Video Controls property in the Properties panel. You can use the blue wireframe controls, the monochrome standard controls, or turn off the controls by choosing None.

• You can also use an Interaction to control the playback of a video. For example, you can hide the video controls in the Properties panel, and then assign interactions (play, pause, stop) to a set of custom buttons.

When someone clicks the Full Screen button during playback, the video opens in a pop-up window. Any interaction used to transition to a new state in the application does not work. If you want the video to play in full screen, do not include a Transition To State interaction in the video controls.

See the following for more information:
“Create action sequences” on page 31
“Edit an action sequence” on page 32
Add sound effects

Sound effects can be added to transitions or action sequences triggered by interactive objects such as button components. You cannot drag sound effects from the Library panel to the artboard.

1. Import sound by choosing File > Import > Video/Sound File. Browse to locate an mp3 file, select it, and click Open. The sound file appears in the Library panel. To preview the sound file, select it in the Library panel, and click the Play button at the top of the panel.

2. Select a transition or action sequence in the Timelines panel. Or, select an interactive object in the artboard.

3. In the Timelines panel, select Add Action > Sound Effect. Choose a sound file and click OK.

Flash Catalyst includes a collection of sounds. These sounds are located in the C:\Program Files\Adobe\Adobe Flash Catalyst CS5\sound effects folder (Windows) or Applications/Adobe Flash Catalyst CS5/sound effects folder (Mac OS).

See the following for more information on adding and controlling sound:

“Interactions and action sequences” on page 30
“Create action sequences” on page 31
“Edit an action sequence” on page 32

Creating video and sound files

There are several applications that you can use to create FLV files and F4V files. You can use Adobe Flash Professional CS5, Adobe Premiere Pro CS5, Adobe After Effects CS5, and Adobe Media Encoder.

You can use Adobe Media Encoder to convert files to the FLV or F4V file formats. Adobe Media Encoder is installed automatically when you install Flash Catalyst. For more information on using Adobe Media Encoder, see Encoding and exporting.

Each of these programs includes many presets. Select a format (FLV/F4V), and choose from a collection of presets, such as Web - Medium Quality for Flash 8 and higher. When you choose a preset, the video and audio codec and other settings are set automatically, including picture size, and frame rate, bit rate. You can also begin with a preset, and then modify individual settings.

Encoding Encoding involves converting video to a format compatible with Adobe Flash Player. Flash Catalyst supports FLV files and F4V files. FLV files and F4V are container formats. FLV files generally contain video data that is encoded using the On2 VP6 or Sorenson Spark codec and audio data encoded using an mp3 audio codec. F4V files generally contain video data that is encoded using an H.264 video codec and the Advanced Audio Coding audio codec.

Whenever possible encode a file from its uncompressed form. If you convert a file that has already been compressed using a different format, and then recompress that file, the previous encoder can introduce video noise.

Codec A codec is an encoding/decoding algorithm that controls how video files compress during encoding, and decompress during playback.

H.264 An MPEG-4-based standard for web delivery. H.264 is recommended for various devices, including high-definition (HD) video, 3GPP mobile phones, and video iPod devices.

On2 VP6 A standard codec for encoding FLV format files for Flash Player 8 and later.
Sorenson Spark  The required video compression format for Flash Player 6 and 7.

mp3  A standard file format on the Internet and many portable digital audio players.

Advanced Audio Coding (AAC)  A standardized encoding scheme for digital audio.

For more information on creating video and sound files, see Encoding and exporting.
Chapter 16: Preview and publish

Using Flash Catalyst CS5, you can preview your projects in a web browser as you work, and publish your final interactive projects as SWF or AIR files. By default, Flash Catalyst generates two versions of a project. One version includes the necessary files to run the project as a web application, but cannot run locally. A second version can run locally, but cannot be run from a web server or launch URLs. There is also an option to build an Adobe AIR application.

- The Run Local version is a larger SWF file with its assets included and no dependencies. The purpose of this version is to share it. For example, you can share the file with a client and they have everything to run the SWF file locally.
- The Deploy To Web version produces a smaller SWF file, along with the Flex 4 framework files externalized.

Note: Since Flash Player 9, the Flex framework is cached. Anyone using Flash Player 9 with the Flex framework, can download the smaller Deploy To Web SWF file from your web server. To support all other users, it is a best practice to put the Flex framework files on the web server next to the SWF file.

Previewing your project in a web browser

It is a best practice to view your work frequently in a web browser before publishing a final version. This allows you to more efficiently check for accuracy and real-world performance.

❖ Choose File > Run Project.

Flash Catalyst launches the project in your default browser.

Select publish options and publish a project

1 Save the project and choose File > Publish To SWF/AIR.

The Build For Accessibility, Build Version For Upload To A Web Server and Build Version To View Offline options are selected by default. The version for upload to a web server can run from a web server. The version to view offline can run on a local system.
Publish To SWF dialog box

2. Select a folder in which to save the project files.

3. To create an Adobe AIR application, select the Build AIR Application check box (optional).

4. To embed fonts in the SWF content, select the Embed Fonts check box (optional). If your project does not include fonts that you can embed, the option to embed is disabled.

   *Embed any fonts other than Arial, Courier New, Georgia, Times New Roman, Verdana. Embedding non-web fonts ensures that users see the design exactly as you do, even if they don’t have the same fonts installed. Click the Advanced button to open the Font Embedding dialog box. You can specify which fonts and character ranges to embed. Limiting what you choose to embed can help reduce the size of your published SWF file.*

5. Click Publish.

Inside the folder you specify, Flash Catalyst creates a subfolder with the same name as your project. Inside this folder, Flash Catalyst publishes a separate folder and files for each version of the project you chose to publish. To deploy your published project to the web, upload the entire contents of the deploy-to-web folder to your web server. You can rename the deploy-to-web folder.

*The published files include the main.html wrapper for the SWF file. This file references the swfobject.js code that performs Flash Player version checks and redirects to upgrade Flash Player. You can reuse this code in your HTML files.*
Optimize application performance

To optimize your application performance and reduce file size, use these strategies:

- Delete objects that are not being used in the application. If an object is not being used in a state (and is not included in a transition), then delete it from that state. Select it and press Delete to remove it from the current state only. If an object is not used in the application, select it and click the Delete button (trash can) in the Layers panel.
- Convert images to linked images.
- Optimize vector graphics using the Optimize Artwork options in the HUD.
- Compress graphics in the Library panel. Right-click a graphic in the Library panel, choose Compression Options, reduce the Quality setting, and choose OK.
- Don’t embed fonts if your users are likely to already have them. If you do embed fonts, use the Advanced button to limit how much of the font is embedded.

See the following for more information on optimizing artwork:

“Optimizing graphics” on page 55
Chapter 17: Extending Flash Catalyst projects using Flash Builder

Although you can use Flash Catalyst CS5 to publish fully functional rich Internet applications many projects require additional development, such as binding components to a data source. A developer completes this phase using Adobe Flash Builder, an integrated development environment (IDE).

**Flash Catalyst and Flash Builder**
Design and development teams work closely to communicate the RIA design vision clearly to each other. After the design is complete, you save it as an FXP file containing MXML code. The developer can then import the FXP file into Flash Builder and add any functionality required by the design. For example, the developer can then add web services or connect to a database. Typically the developer does simple cleanup tasks before adding code. Cleanup includes removing metadata added by Illustrator, Flash Catalyst, and other applications.

After the developer adds services, data hookups, and other back-end functionality, further changes can only be made in Flash Builder. However, you can make design refinements in Flash Catalyst and hand off an updated FXP for the developer to merge with their copy of the project. Best practices make collaboration easier by keeping the developer's code mostly separate from the code created by Flash Catalyst.

- Before you design in Flash Catalyst, determine if the project requires development in Flash Builder.
- If the application includes large records of data, then store the data externally and bind components to the data using Flash Builder.
- If your application presents a list of items from an external source, you do not need to add every item to the component in Flash Catalyst. Instead, add a few design-time data items as a prototype.
- If designing a Flash Catalyst project for Flash Builder, meet with your developer first to discuss which Flash Catalyst components and properties to use.
- If the application uses web services, then create the input controls in Flash Catalyst and let your developer bind controls to the service using Flash Builder wizards.
- Use descriptive names for all layers and objects in the Layers panel.
- Give all library assets unique names that the developer can recognize.
- Remove all library content that is not used in the project.
- Give unique and identifiable names to all page states, components, and component states.

See the following for more information on Flash Builder integration:

- [Support for Catalyst projects](#)
- [Importing a Catalyst FXPL project](#)
- [Resolving font references when importing Catalyst projects](#)
- [Importing a Flex project or Flex library project](#)
- [Using Flash Builder](#)
Chapter 18: Keyboard shortcuts

Keyboard shortcuts let you quickly select tools and execute commands without using a menu. When available, the keyboard shortcut appears to the right of the command name in the menu.

In addition to using keyboard shortcuts, you can access many commands using context-sensitive menus. Context-sensitive menus display commands that are relevant to the active tool, selection, or panel. To display a context-sensitive menu, right-click (Windows) or Control-click (Mac OS) an area.

Note: Shortcuts work in all modules on full-size U.S. keyboards unless otherwise indicated. Functionality may vary on other keyboards and in other languages.

Viewing and navigating the workspace

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toggle between Design and Code workspace</td>
<td>Ctrl + `</td>
<td>Command + `</td>
</tr>
<tr>
<td>Refresh the artboard view</td>
<td>F5</td>
<td>F5</td>
</tr>
<tr>
<td>Show/Hide all workspace panels</td>
<td>F4 or Tab</td>
<td>F4 or Tab</td>
</tr>
<tr>
<td>Show/Hide HUD</td>
<td>F7</td>
<td>F7</td>
</tr>
<tr>
<td>Zoom in</td>
<td>Ctrl + = or Ctrl + +</td>
<td>Command + = or Command + +</td>
</tr>
<tr>
<td>Zoom out</td>
<td>Ctrl + -</td>
<td>Command + -</td>
</tr>
<tr>
<td>Fit in artboard window</td>
<td>Ctrl + 0</td>
<td>Command + 0</td>
</tr>
<tr>
<td>Change to 50% magnification</td>
<td>Ctrl + 5</td>
<td>Command + 5</td>
</tr>
<tr>
<td>Change to 100% magnification</td>
<td>Ctrl + 1 or Ctrl + Alt + 0</td>
<td>Command + 1 or Command + Option + 0</td>
</tr>
<tr>
<td>Change to 200% magnification</td>
<td>Ctrl + 2</td>
<td>Command + 2</td>
</tr>
<tr>
<td>Change to 400% magnification</td>
<td>Ctrl + 4</td>
<td>Command + 4</td>
</tr>
<tr>
<td>Change to 800% magnification</td>
<td>Ctrl + 8</td>
<td>Command +8</td>
</tr>
</tbody>
</table>
### Keyboard shortcuts

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show rulers in artboard</td>
<td>Ctrl + R</td>
<td>Command + R</td>
</tr>
<tr>
<td>Show grid in artboard</td>
<td>Ctrl + ‘</td>
<td>Command + ‘</td>
</tr>
<tr>
<td>Snap to grid</td>
<td>Ctrl + Shift + ‘</td>
<td>Command + Shift + ‘</td>
</tr>
<tr>
<td>Lock guides</td>
<td>Ctrl + Alt + ;</td>
<td>Command + Option + ;</td>
</tr>
<tr>
<td>Show guides</td>
<td>Ctrl + ;</td>
<td>Command + ;</td>
</tr>
<tr>
<td>Snap to guides</td>
<td>Ctrl + Shift + ;</td>
<td>Command + Shift + ;</td>
</tr>
<tr>
<td>Modify artboard settings</td>
<td>Ctrl + J</td>
<td>Command + J</td>
</tr>
<tr>
<td>Text search in the Code workspace</td>
<td>Ctrl + F</td>
<td>Command + F</td>
</tr>
<tr>
<td>Access community help</td>
<td>F1</td>
<td>F1 or Command + ?</td>
</tr>
</tbody>
</table>

### Creating and running projects

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a new project</td>
<td>Ctrl + N</td>
<td>Command + N</td>
</tr>
<tr>
<td>Save a project</td>
<td>Ctrl + S</td>
<td>Command + S</td>
</tr>
<tr>
<td>Save a project as a new file</td>
<td>Ctrl + Shift + S</td>
<td>Command + Shift + S</td>
</tr>
<tr>
<td>Save a copy of a project</td>
<td>Ctrl + Alt + S</td>
<td>Command + Alt + S</td>
</tr>
<tr>
<td>Open an existing project</td>
<td>Ctrl + O</td>
<td>Command + O</td>
</tr>
<tr>
<td>Close a project</td>
<td>Ctrl + W</td>
<td>Command + W</td>
</tr>
<tr>
<td>Run the project in a browser</td>
<td>Ctrl + Enter</td>
<td>Command + Return</td>
</tr>
<tr>
<td>Exit the Flash Catalyst application</td>
<td>Ctrl + Q</td>
<td>Command + Q</td>
</tr>
</tbody>
</table>
## Working with pages and states

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply the same properties to all instances of the same object in other states</td>
<td>Ctrl + Alt + M</td>
<td>Command + Option + M</td>
</tr>
<tr>
<td>Add a new blank state</td>
<td>Ctrl + Shift + B</td>
<td>Command + Shift + B</td>
</tr>
<tr>
<td>Duplicate a state</td>
<td>Ctrl + Shift + D</td>
<td>Command + Shift + D</td>
</tr>
<tr>
<td>Share (copy) an object to all other states</td>
<td>Ctrl + Alt + A</td>
<td>Command + Option + A</td>
</tr>
<tr>
<td>Delete from all states in the application</td>
<td>Ctrl + Del</td>
<td>Command + Del</td>
</tr>
<tr>
<td>Delete from current state</td>
<td>Del or Backspace</td>
<td>Del or Backspace</td>
</tr>
</tbody>
</table>

## Selecting tools in the Tools panel

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Direct Select tool</td>
<td>A</td>
<td>A</td>
</tr>
<tr>
<td>Select tool</td>
<td>V</td>
<td>V</td>
</tr>
<tr>
<td>Hand tool</td>
<td>H</td>
<td>H</td>
</tr>
<tr>
<td>Transform (rotate) tool</td>
<td>Q</td>
<td>Q</td>
</tr>
<tr>
<td>Zoom tool</td>
<td>Z</td>
<td>Z</td>
</tr>
<tr>
<td>Text tool</td>
<td>T</td>
<td>T</td>
</tr>
<tr>
<td>Rounded Rectangle tool</td>
<td>U</td>
<td>U</td>
</tr>
<tr>
<td>Rectangle tool</td>
<td>M</td>
<td>M</td>
</tr>
<tr>
<td>Ellipse tool</td>
<td>L</td>
<td>L</td>
</tr>
<tr>
<td>Line tool</td>
<td>N or \</td>
<td>N or \</td>
</tr>
</tbody>
</table>
## Converting artwork to components

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Convert artwork into a Button component</td>
<td>Ctrl + Shift + U</td>
<td>Command + Shift + U</td>
</tr>
<tr>
<td>Convert artwork into a Text Input component</td>
<td>Ctrl + Shift + I</td>
<td>Command + Shift + I</td>
</tr>
<tr>
<td>Convert artwork into a Custom/Generi c component</td>
<td>Ctrl + Shift + C</td>
<td>Command + Shift + C</td>
</tr>
</tbody>
</table>

## Modifying and editing objects

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open a component in Edit-In-Place mode</td>
<td>Ctrl + E</td>
<td>Command + E</td>
</tr>
<tr>
<td>Open artwork for editing in Adobe Illustrator CS5</td>
<td>Ctrl + Alt + L</td>
<td>Command + Option + L</td>
</tr>
<tr>
<td>Open artwork for editing in Adobe Photoshop CS5</td>
<td>Ctrl + Alt + P</td>
<td>Command + Option + P</td>
</tr>
<tr>
<td>Group selected objects</td>
<td>Ctrl + G</td>
<td>Command + G</td>
</tr>
<tr>
<td>Apply the same properties to all instances of the same object in other states.</td>
<td>Ctrl + Alt + M</td>
<td>Command + Option + M</td>
</tr>
<tr>
<td>Bring to front</td>
<td>Ctrl + Shift + ]</td>
<td>Command + Shift + ]</td>
</tr>
<tr>
<td>Send to back</td>
<td>Ctrl + Shift + [</td>
<td>Command + Shift + [</td>
</tr>
<tr>
<td>Bring forward</td>
<td>Ctrl + ]</td>
<td>Command + ]</td>
</tr>
<tr>
<td>Send backward</td>
<td>Ctrl + [</td>
<td>Command + [</td>
</tr>
<tr>
<td>Left-align selected objects</td>
<td>Ctrl + Alt + 1</td>
<td>Command + Option + 1</td>
</tr>
</tbody>
</table>
### Keyboard shortcuts

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Horizontal-center selected objects</td>
<td>Ctrl + Alt + 2</td>
<td>Command + Option + 2</td>
</tr>
<tr>
<td>Right-align selected objects</td>
<td>Ctrl + Alt + 3</td>
<td>Command + Option + 3</td>
</tr>
<tr>
<td>Top-align selected objects</td>
<td>Ctrl + Alt + 4</td>
<td>Command + Option + 4</td>
</tr>
<tr>
<td>Vertical-center selected objects</td>
<td>Ctrl + Alt + 5</td>
<td>Command + Option + 5</td>
</tr>
<tr>
<td>Bottom-align selected objects</td>
<td>Ctrl + Alt + 6</td>
<td>Command + Option + 6</td>
</tr>
<tr>
<td>Exit Edit-In-Place mode</td>
<td>Esc</td>
<td>Esc</td>
</tr>
<tr>
<td>Nudge by 1 pixel</td>
<td>Arrow keys</td>
<td>Arrow keys</td>
</tr>
<tr>
<td>Nudge by 10 pixels</td>
<td>Shift + Arrows</td>
<td>Shift + Arrows</td>
</tr>
<tr>
<td>Undo a change</td>
<td>Ctrl + Z</td>
<td>Command + Z</td>
</tr>
</tbody>
</table>

### Working in the Properties panel

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toggle the eyedropper on/off in a color picker</td>
<td>I</td>
<td>I</td>
</tr>
<tr>
<td>Change numeric values incrementally up or down</td>
<td>Up/Down Arrows</td>
<td>Up/Down Arrows</td>
</tr>
<tr>
<td>Jump to maximum or minimum allowed values</td>
<td>Page Up/Page Down</td>
<td>Page Up/Page Down</td>
</tr>
</tbody>
</table>

### Working with transitions and action sequences

<table>
<thead>
<tr>
<th>Result</th>
<th>Windows</th>
<th>Mac OS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a new interaction</td>
<td>Ctrl + Alt + I</td>
<td>Command + Option + I</td>
</tr>
<tr>
<td>Result</td>
<td>Windows</td>
<td>Mac OS</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>--------------------------</td>
<td>---------------------------</td>
</tr>
<tr>
<td>Play/Stop in the Timeline</td>
<td>Ctrl + Shift + P or Enter</td>
<td>Command + Shift + P or Return</td>
</tr>
<tr>
<td>Add smooth transitions</td>
<td>Ctrl + Alt + T</td>
<td>Command + Option + T</td>
</tr>
</tbody>
</table>